Trouble installing 1.8


#1

Hi cslaughter,

Can you help me out with the steps for installing xibo1.8 apha2 I am kinda stuck at

I have enable the rewrite function in .htaccess file still i am not able to proceed beyond this step. Tried with apache.


1.8 Alpha, ZMQ, Windows - Informational
Rewrite not working
Upgrade manually from 1.7.9 to 1.8 not working
#2

Well I can try. Can you give me a brief back ground of how you got to this point? Os version? Did you pass all the prerequisites?

Also just so you know, I had to tweak my .htaccess file a bit to get my test server to work correctly. Here is what i have at the moment. Keep in mind, this is for a test server, and there may be things configured in such a way that they should not be used in a production environment.

Options +FollowSymLinks
RewriteEngine On
RewriteBase /xibo18alpha/web/

RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]


# requests for api authorize
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/authorize/.*$
RewriteRule ^ api/authorize/index.php [QSA,L]

# requests that start with api go down to api/index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/api/.*$
RewriteRule ^ api/index.php [QSA,L]

# install
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/install/.*$
RewriteRule ^ install/index.php [QSA,L]

# maintenance
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_URI} ^.*/maint/.*$
RewriteRule ^ maint/index.php [QSA,L]

# vendor
RewriteCond %{REQUEST_URI} ^.*/vendor/.*$
RewriteRule ^ ../vendor/ [QSA,L]

# all others - i.e. web
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php [QSA,L]

Xibo 1.8.2 layout preview errors
#3

As @cslaughter says, we will need far more information on your environment than you have given in order to help you out. Please can you describe your environment exactly (os, web server, versions of everything, installation folder, web root (apache conf), etc.


#4

Hi cslaughter and dan,

Thanks for prompt support. We are running on Windows 2008 server 64 bit, with Xampp version 3.2.2. Its installed in root folder “C:\xampp” and xibo1.8 alpha2 in “C:\xampp\htdocs\xibo-cms”. I passed all prerequistes.


#5

I will assume that IIS is not installed or at least not running? So then, I would think the .htaccess file would be the problem. During installation did everything look bland and a little out of place like the screen shot above? I will also assume that you ran composer?

Does your .htaccess file contain the first three lines I have in mine? Keep mind that of course your RewriteBase would be “/xibo-cms/web/”, I believe.

If you can supply a bit more information as Dan has suggested, the level of precision should increase.


#6

hi cslaughter,

I am running apache and iis both. Currently 1.7.6 version is running on IIS. I have my .htaccess file in apache foler /xibo-cms/web/ added with required lines. I still dont know about composer or how to run it. I read the documentation on XMR, but unaware about composer. Can you help me out? The installation did look out of place same like i have attached my screenshot.

regards,
Prakash


#7

XMedia,

How are you handling the request on port 80 for both IIS and Apache?

I have my .htaccess file in my root folder, so you may want to move that up a couple of levels on the directory.

You only need to run composer if you are not using an archive build. Meaning you are not downloading the latest code from Github. If you are using the link provided on the community here for Alapha2 then, as I understand it, you will not need to worry about composer.


#8

The symptoms you have usually mean that there is something wrong with the way you have your web server set up - or that your URL rewriting is wrong.

It sounds to me like your “web root” is C:\xampp\htdocs and you have put the entire release archives into that folder - this is not a supported configuration. You must be having to access it via http://localhost/xibo-cms/web/?

If you are running only Xibo then the easiest way to solve the issue is to change your DocumentRoot in your xampp apache config file to: C:\xampp\htdocs\xibo-cms\web.

If you have other things running too, it might be better to use an alias (http://willi.am/blog/2011/02/24/creating-xampp-alias-directories/). If you do that don’t forget to modify your .htaccess file (see Rewrite Rules with an Alias.


#9

Hello guys…i tried installing the 1.8 Beta and this due to the dire need for AD log on and this is the error i get.

Fatal error: Uncaught exception ‘RuntimeException’ with message ‘Unable to create the cache directory (C:\inetpub\xibo/cache/8f).’ in C:\inetpub\xibo\vendor\twig\twig\lib\Twig\Cache\Filesystem.php:60 Stack trace: #0 C:\inetpub\xibo\vendor\twig\twig\lib\Twig\Environment.php(400): Twig_Cache_Filesystem->write(‘C:\inetpub\xibo…’, ‘<?php\n\n/* insta…’) #1 C:\inetpub\xibo\vendor\slim\views\Twig.php(88): Twig_Environment->loadTemplate(‘install-error.t…’) #2 C:\inetpub\xibo\vendor\slim\slim\Slim\View.php(255): Slim\Views\Twig->render(‘install-error.t…’, NULL) #3 C:\inetpub\xibo\vendor\slim\slim\Slim\View.php(243): Slim\View->fetch(‘install-error.t…’, NULL) #4 C:\inetpub\xibo\vendor\slim\slim\Slim\Slim.php(757): Slim\View->display(‘install-error.t…’) #5 C:\inetpub\xibo\web\install\index.php(58): Slim\Slim->render(‘install-error.t…’, Array, 500) #6 [internal function]: {closure}(Object(UnexpectedValueException)) #7 C:\inetpub\xibo\vendor\slim\slim\Slim\Slim.php(656): call_user_func_array(Object(Closure), Array) #8 in C:\inetpub\xibo\vendor\twig\twig\lib\Twig\Cache\Filesystem.php on line 60

any pointer will be appreciated


#10

fixed this by granting write access for my user(not iis user) on folder. Now i am stuck at http://pathto/xibo/install/2 "not found"error 404


#11

Try http://pathto/xibo/install/index.php/2 - and if that works you’ve got mod_rewrite problems.

If you are using IIS then the .htaccess file we provide won’t be suitable and you will need to set equivalent rules in your IIS config.

Something like this would be a good start:

<configuration>
<system.webServer>
    <rewrite>
        <rules>
            <rule name="xibo auth" enabled="true">
                <match url="api/authorize/.*" />
                <action type="Rewrite" url="/api/authorize/index.php" />
            </rule>
            <rule name="xibo api" enabled="true">
                <match url="api/.*" />
                <action type="Rewrite" url="/api/index.php" />
            </rule>
            <rule name="xibo install" enabled="true">
                <match url="install/.*" />
                <action type="Rewrite" url="/install/index.php" />
            </rule>
            <rule name="xibo maint" enabled="true">
                <match url="maint/.*" />
                <action type="Rewrite" url="maint/index.php" />
            </rule>
            <rule name="xibo web" enabled="true">
                <match url=".*" />
                <action type="Rewrite" url="/index.php" />
            </rule>
        </rules>
    </rewrite>
</system.webServer>

^^ that is a guess based on some googling


Xibo 1.8 CMS setup on IIS for Windows 2008 server
404 login error while upgrading CMS
#12

Thanks peter…i imported the .htaccess into IIS rewrite rule and that was it.

Love you guys!!!


#13

Can you let us know the exact rules you used (was it the ones in our post?!) - we can add them to the manual


#14

I asked IIS to convert the same rules from the .htaccess and installation was smooth.

I was forced to delete two of the rules during conversion just as …

afterwards…installation/upgrade went on fine.

I however had a few ajax exception for tables on 1.8 so i rolled back to 1.7.9.


#15

I ran into the same ajax issue. Is it because of the rewrite rules that doesn;'t work


#16

The AJAX errors may be something different - if someone could provide a developer tools log then I can further comment


#17

I’m facing the same issue with IIS 8.5 so I’ve added these rewrite rules exactly as stated above but now when I run http://localhost:8000/ (i’m using 8000 port) it gives a “HTTP Error 404.20 - Not Found” and the browser URL turn into: http://localhost:8000/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/install/

I think it’s a rule issue, but I couldn’t trace which. Could you help me on that?

Thanks,

Beto

UPDATE:
I’ve removed the last rule and were able to complete the setup. After that I had the same 404.20 issue on login page. Thus I added the last rule back. I’m able to login but the Xibo pages are completely messy.


#18

That would be because the resources cannot be loaded correctly, because the rules are wrong :slight_smile:

Unfortunately no-one who has it working has been able to post the contents of their rules file - so I do not know if the above actually worked for them.

Perhaps you could follow the procedure they said worked?


#19

I’ve imported the .htaccess file on IIS (excluding the incompatible rule) and everything looks good now.

Thank you for your support.

Beto


#20

Another issue to beat: Any configuration change done on settings page, I receive the following message on clicking Save:


Any idea why?
Thanks,
Beto