Trouble installing 1.8


#21

Can you export the resulting rules so that we can pop them in our user manual?

That is strange - do other forms work? That message would imply that IIS isn’t configured for PHP correctly (which seems very odd) or that the rewrite rules are directing requests for that specific page to a different place.


#22

We were able to get up and running on IIS using the same method.

After that, we ran into the same AJAX errors. It turns out they were caused by IIS rejecting the query string for being too long. We fixed this by changing the max query string in IIS. There are more details in this post:

https://community.xibo.org.uk/t/1-8-rc1-install-media-problems/8040


#23

I’ll add the “import .htaccess” instruction into the manual as well.


#24

I’m seeing this same issue. 405 errors when trying to apply a change on the settings page. The debug tools in Chrome say that the PUT method isn’t allowed which is weird because I swear I use PUT with other php pages/sites on this server.


#25

I just tried to edit an existing user and got the same 405 error. When creating a user I don’t get an error because the method used is POST but when I try to edit an existing entry the PUT method is used and that is getting blocked.
Under 1.7.4 the method used for both creating and updating a user is POST.
Is this the way edits are intended to update in 1.8?


#26

Nevermind, I seemed to have missed the http verbs section of this article: http://xibo.org.uk/manual-tempel/en/install_environment_windows_iis.html#http_verbs. Once I switch the verb list to “*” it works.


#27

Thanks. It solved my problem. I made all directly from IIS Manager (just change to All verbs) as the screen shot.
IIS needs double quota for save this settings. Please look for the Module line.


#28

I am still having problems with receiving a 405 HTTP Verb error. I believe everything is done correctly with the HTTP Mapping in IIS, I don’t know if there’s a extra step I need to figure out with plesk? Any help would be much appreciated :slight_smile: