Problem to display on Client from Server (Version. 1.7.6)


i have a problem with Xibo

i have two Windows7 computers.
i use one computer as Xibo Server (Version 1.7.6) and the other as Client (Version 1.7.6)
language settings on windows and xibo is german.

when i click on displays on the server, i see the Display of the Client.
There is a exclamation mark under status.
it says “display is out of date but has not yet checked in with the server”

when i click “schedule now” and select the default layout on the server, nothing happens on the client. You can see only the "Xibo Open Source Digital Signage"
i pressed “i” on the client and there is an error message. “MainForm - ChangeToNextLayout” on the left side and on the right side “Prepare Layout failed. Exception raised was: Default layout” and “Layout change to failed. Exception raised was: Default layout”.

i tried this links:

and i also clicked on “modules” on "verify all"

thank you in advance

Is your display logged in to your CMS?
It should make connection attempt each collection interval - and since there is new content to download after it will know about it, it should attempt to download it.

The default layout that is currently displayed on your client, does it have any long durations on it?
Is the default / other scheduled layouts valid in the CMS?

Is the download window open?

Perhaps you could show us whole screenshot of status screen please?

we are also still experiencing this, the display log certainly shows the display checking in, all media and layouts up to date.

Good Evening

Thank You for your Help

Here are the Screenshots from …



i copied the text from the XIBO PLAYER OPTIONS:

Thank You in advance

What’s your php version? Is SOAP extension correctly installed/enabled?

Perhaps also open php.ini and change ‘always_populate_raw_post_data’ to ‘-1’

Of course also double check that CMS URL and key are correct.

Hello Peter

Thank you very much for your help!

After i opened “php.ini” there was “always_populate_raw_post_data -1” commented, so i comment it out and restart Apache and MySQL.

Now it works :slight_smile:

Kind regards