Xibo Checklist for CMS Installation

ok I am new to Ubuntu and Xibo. most everything has been easy to follow and fix. lol for me it was not an easy install and everything that could cause problems seems to have done just that. I am using Ubuntu 16.4 and xibo 1.7.9 all checklist ticks have been completed except for 2 exclamation points on large file uploads and internationalization. I have edited the php.ini file to everything recommended and the ticker will not go away. current changes to the php. ini file include Post_max_size = 128M

Max_execution_time = 120
max_input_time= 120 (changed because recommended changes didn’t help)
upload_max_filesize = 128M

I have restarted apache2 and the complete server with no change

I have searched through documentation and found nothing related to my current problems.

on the international tick I can’t even find where to change anything. I’m sure its just because all of this is new, but just direction where to make changes would be great. I haven’t found any help or saw where anyone else had this problem.

There are sections for these options in the FAQ, have you seen those yet?


If these aren’t useful in helping you resolve the issue, please let us know.

I finally found the name of the internationalized package that was giving me issues and reinstalled that to fix that problem php5.6-intl fixed that for anyone else reading. just restarted the server after and it was all good. My setup is on Ubuntu 16.4 also not windows. I think most of this came from Ubuntu wanting to use php 7. Seven will not work it must be removed and php5.6 installed back on. there are good articles on that out there.

I’m down to one exclamation point which is the large file. yes I have read all of those articles. this is on the checklist to install the CMS, so I don’t have any errors or post problems this is all still Pre requisite stuff. I still looked over that article again since you recommended it. Unless you are saying to make My setting like the ones in that article (How do I upload files bigger than 2MB / How can I increase the upload file size limit?) which isn’t like the ones on your Xibo website or the tick list recommendations, the rest doesn’t apply. instructions said do not install unless all ticks are completed. All ticks are not completed until the Large file issue is done. I’m not doing anything with a library or errors yet. I’m still preparing to install CMS. So here is where the questions come in. if I have adjusted all the php.ini file things. saved the file back to original folder and restarted the server. where is the checklist pulling from besides in that php.ini file. or what else in that php.ini file could be the problem. That is what I am trying to find out since CMS hasn’t ever been installed? What do you think?

Ok so I changed all the settings to exactly like this article: How do I upload files bigger than 2MB / How can I increase the upload file size limit?

This didn’t stop the Large file uploads exclamation tick either. something else is going on.

Ok I have solved all the checklist ticks now here was how I handled most of the problems up to these comments.


keep in mind the 5.6 install packages can not all be seen until you click on that box to get the whole list.

The large File tick problem was solved after I installed the phpinfo.php file and could see the number xibo was using. I then realized that it was pulling from another php.ini file.

the file I was editing was at /etc/php/5.6/fpm
the file Xibo pulls from is in /etc/php/5.6/apache2
when you do all the file adjustments from that php.ini file it all changes for the install.
I hope this help someone troubleshoot future problems
I am now ready to install CMS!