Will not pull content

Upgraded CMS to 1.7.7 and the Player to latest versions. The player does not display current content but CMS says its upto date. Which its not. Please help.

Curious if you tried to reboot the client. When we see this on our displays, we usually just need to to restart the Xibo Client. Can you get a screenshot of the status window of the client? It might provide some additional information.

I have tried restarting the client, even so far as fresh install of Windows. It says my test layout is displaying. But it’s still display xibo default layout. Even done a fresh install of CMS.

Can you give us a screenshot of the status window of the Client? Also a screenshot of the client error log might help.

How do I get client error log??

tablet on left has 1.7.7 lastest client software and on right with the clock is the TEST layout has client software 1.7.3 they is nothing in my CMS log. As you see both are online, status is ok and both. Anyone else having this issue.

For Windows client you can press i on the client to toggle its information window open / close. If you’re running xibo on tablets, I’m guessing those are android. I’m not sure if it’s the same for the xibo android client.

My first troubleshooting action would be to purge the local library on the misbehaving one.

my clients are Windows 10 tablets. Has been working fine on previous version of CMS and Client software.

So it says that it’s displaying layout 5 (is it? I mean is that the id of your default layout 'Welcome to Xibo…")

In Required files there is also layout 7 downloaded - is that the one with the clock? Is it scheduled to display on that tablet now?

You might want to ‘verify all’ on Modules page.

Restart your client, give it a moment to reconnect.

failing that perhaps it’s a library path problem, did you specify fully qualified path in CMS?(settings->configuration)

Layout ID 7 is the clock which it is not displaying just stuck in the welcome to xibo ID 5. The screen flashes for a split second if it suppose to display Layout ID 7 but doesn’t and still displays ID 5. I will verify all modules later. I did see on another post about this qualified library. But must be something new as Iv not had any issues before with xibo just this latest update. All that said the library is library/ in the CMS settings. So if you can help it would be great.

yeah if the verify all / restart won’t help then fully qualified path to CMS library could help.

So you can have a look at this topic:
1.7.7 unsolved bug?


You would need to know where exactly is Xibo CMS library located on your web server and enter that full path in CMS settings.

Say your web root is /var/www/xibo and therefore your CMS library is currently at /var/www/xibo/library/ then the setting in the CMS should be /var/www/xibo/library/

Ok will try that later. Xibo CMS knows we’re the library is as its storing the media Iv uploaded. But will try that also. If I carnt get it to work I message back on here

it might be also worth checking if it will work if you set layout 7 as a default layout.

If it does, then check if you have correct date/time settings in CMS/client.

Some parts of Xibo may be able to locate it from a relative path, but we do specifically say it must be a fully qualified path, so please ensure the path you have set there is indeed fully qualified.

Peter, can I DM you ro login to my server for you to have a play.

Alex, I have xibo (Wids we call it) on a domain ref here: and library in CMS is library/ so would my qualified be var/

The external URL has no bearing on the actual path on the server - well it may do, but the two don’t have to follow each other.

From the server’s filesystem, find the library directory and then get it’s full path. If you’re not sure, a sysadmin there will be able to help you.

i don’t know what fixed my issue if it was verifying the modules or the fully qualified path. but its now working.

Well, that’s good, I’m glad to hear it :slight_smile: