1.7.7 unsolved bug?

I make upgrade to 1.7.7 CMS.
In reference to the following bug:
Invalid layout with “?” status in CMS #727

I notice that after upgrade simple layout with no website region now show “?”…in some case client after cms upgrade don’t show animation because the layout i s invalid…

Can you help me please? Thanks

The ? marker is there as a guide.

It refreshes in the background so it may sometimes take a few seconds after you change the layout for it to update. It has absolutely no bearing on whether the Player considers the layout valid or not - that’s the Player’s own assessment.

After a couple of hour the marker is still “?”

I noticed that in the layout where there are web pages unless you update the client to version 1.7.7 the layout is invalid.

I knew that was’nt necessary to update client to the latest fix to work …at least in previous versions it was so.
Can you verify please?

So to clarify, if I make a layout with one region with the video in it you think I’ll get ? for the status?

I don’t understand how that relates to the Player. It doesn’t have access to or use that marker

I tried that configuration:

I get a tick with a single video in a region.

The only reason you would get a ? is if there’s something on the layout that has to be evaluated Player side - eg a webpage, embedded HTML element etc.

In this layout I’ve only one region with a mp4 video and i’ve “?”

In this layout I’ve 3 region with one web page and i’ve “?” (correct)

In both cases I was able to update player only wit ugrade to 1.7.7 version, otherwise the layout was not valid.

Is it normal?


If you have a Webpage on the layout then it will always be a ? So that’s completely expected.

With regards to your video layout, you must have something else on it. If not, try a small edit and I expect the status will update to a tick. As I’ve already explained though it’s just an indication. It won’t effect the Player downloading or playing a layout.

You are always advised to run matched versions of the Windows Player and CMS. So if upgrading to 1.7.7 worked with playing your layouts then that’s fine. There’s no reason 1.7.6 shouldn’t work though. To know why it didn’t we’d need to see the status screen from the Player. Most likely you had missing files preventing the layout being valid.

I’ve run a test with 1.7.7 CMS and 1.7.6 Player.

In the CMS, I create a layout with a webpage on it:

Status is ? as expected.

When scheduled to the Player, the Player runs the layout as expected.

The message in there saying that the layout is invalid is simply because at the time the layout is checked, the resources for it haven’t finished downloading. As soon as they have, the layout starts running.

Thanks Alex but I’ve problems with layout…the “?” appears in simple layout with no webpages or external content and results invalid when I try to change contents and dowload it from client.

This also happens on the scheduled layout … I opened another more specific topic about it:

It doesn’t on any of the CMS we have here. If you’d like to send over a layout I can have a look. It sounds to me like there’s a bigger problem underlying your issue. Perhaps the permissions on your library directory are wrong or you didn’t delete the old CMS files when you upgraded?

yesterday I upgrade cms to 1.7.7 fix (follow instructions), after that i’ve problems with update content from client to server and sheduling.

For example I can’t update content of a layout unless I empty before local library. I also have scheduled contents before the upgrade, and now if I try to change schedule don’t work. I upgraded Windows client to version 1.7.7.

What can I do? What you need to help me? Thank you!

Edit: client show only cached scheduled content.
Here is the log:

1008 16-04-15 09:52:41 Zanconato (XP) XMDSSoap4 RequiredFiles Returning required files from Cache for display Zanconato (XP) key display/69/requiredFiles
1007 16-04-15 09:52:41 Zanconato (XP) XMDSSoap4 RequiredFiles hardwareKey = zanconato-spot-29022016

In fact, I deleted the schedule but client continues to show that …

I’ve moved your other posts in here as it all seems linked to me.

1.7.7 has some extra caching on the webserver side of the data it returns to the Player since calculating the schedule and required files is computationally expensive.

Firstly please ensure the permissions are correct on the CMS library and all it’s sub directories, then delete the contents of the cache directory inside the CMS library.

The Player will then collect and download fresh data. Then make a schedule change and immediately see what the status of the Player is in the Displays section. It should be ! (updated content but the Player hasn’t connected yet) until the Player collects, then it will change to a X as the Player downloads the updated information, and finally will change to a tick.

Here is the layout:

I deleted the old CMS before upgrading and the library permission are the same of the 1.7.6 version…

Sorry Alex cache folder called “cache” and it’s under the library right? I currently haven’t access to the server and I’ve to ask the administrator … thank you!

Your Flash content triggers the ? status. The CMS can’t know if that is a valid flash file or if it will run properly on your Player so it marks the layout as ? to signal that.

1 Like

Yes it’s cache in the server library. You need to make sure that the server library path is fully qualified in the CMS settings too - ie it’s something like

/path/to/library/ or c:\path\to\library/

not just


ok I asked the administrator to clear the cache folder.

In the CMS settings I have this:

I have to change with “/multimedia /” ? The folder is located in the site root. Thank you

It seems that the main problems with download of new content and scheduling are present on older XP client… possible?

I have another customer with 2 monitors, one with XP and one with WIN 7. From Win 7 client can download new content while on XP not. Both clients have the 1.7.7 version

multimedia/ will be a folder called multimedia in the same location as your Xibo install.

That means that anyone with access to your CMS webserver can download your content unauthenticated.

What should be in there, is the fully qualified path to your library.

So say your web root is /var/www/xibo and therefore your CMS library is currently at /var/www/xibo/multimedia then the setting in the CMS should be /var/www/xibo/multimedia/

But as I said, that means anyone with access to your webserver can browse to say http://yourwebserver/multimedia and download your content.

What you should have is a folder for the library outside the webroot - eg /opt/xibolibrary. That way access to your media is controlled properly by Xibo.

For now, I’d change that path to be fully qualified (ie change it to the full path to your multimedia directory - /var/www/xibo/multimedia/ for example) and worry about moving it out of the webroot later on.

With regard to the Players not downloading content, what does the Player status screen show?