Problem with xibo client config

Dear Xibo,

I have an issue with a xibo client : yesterday it failed to start and I had the following error message : there exists an error in the xml (0,0) with following file : xiboclient.config.xml.

I did not manage to solve the issue so I uninstalled the player and deleted all xibo files and then reinstalled it.

At the end of the installation :

  • The client failed to launch and I had the same error message
  • I could not find the “xibo player option” file… which is normally required to set up the player…

I do not know very much about code and computer… Do you have a simple way to solve that ?

Thank you very much for your answer,

All the best

Cedric

Try deleting your XiboClient.config.xml file and then reload the Player options.

It sounds like that file has become corrupted or has been manually edited badly and it’s now invalid.

It can be found in %appdata% directory - so on my laptop it’s:

C:\Users\alex\AppData\Roaming\XiboClient.config.xml

Thank you for your reply Alex,

The players are in a shopping center so I cannot access them right now.

Yesterday I tried to check this xiboclient.config.xml file but I have never been able to find it in my directory…
Moreover, as I told you, I no longer have access to client options (no icon on the desktop).

It is really strange because I managed to install a new xibo client on another computer without any issue 2 days ago so installation files are not corrupted…
It is as if the installation did not go well on this very computer and some parts of it were missing…

I don’t know if it helps…

We don’t make any desktop shortcuts. You can find the Player settings shortcut on the start menu.

Sorry Alex, that is what I meant, I cannot find it in the start menu…

Error message is the following : There is an error in XML document (0,0)… Path C:\Documents and Settings\Username\Application Data\xiboclient.config.xml

And I don’t find this file…

Thank you

The installer will definitely put the shortcut there.

The error is probably saying then that the Player can’t read the file as it’s never been configured. Did you install the Player as the same user you’re running it as?

Yes I did. But anyway, it worked perfectly fine for the last 8 months.
All of a sudden I have the message with this xml document error.
So I tried to uninstall and reinstall it without success.

Now I can see the shortcut in the start menu but once again I have the same message with the error in the xml document…

Thank you for your help :wink:
For an open source solution, you are quicker than paid solution to manage issues !

That file will be hidden by default and you will need to “Show Hidden Files and Folders” in Windows Explorer. If you delete the file it should be recreated from defaults (you will need to reconfigure the player)

The newer version of the player (1.7.6 which we will release very soon) prevents this problem from happening.

OK thank you Dan, we will try that tomorrow when we are at our client’s office.
I will let you know.

All the best

1 Like

This issue has been resolved? as? I’m having this same problem.

1.7.6 should resolve the root cause such that the settings file in question is never empty… if you are unlucky enough to already have an empty file you will need to delete it and reconfigure your player from the options screen.

I have tried to delete the configuration file but it has not changed anything… When will 1.7.6 be released ?
Thank you for your help !

It was released yesterday - but as I said, if you are getting that error message it won’t fix it (it only prevents it being a problem in the first place).

Deleting the config file absolutely will fix the issue I am thinking of, so either you’ve deleted the wrong file or we are thinking of different issues :smiley:

Thank you Dan, I did both (delete the file and update the player) and it worked :smile:

All the best,

Cedric

1 Like