Blank Screen on Client

This problem appears to be related to two problems (Xibo client stops working - black screen and Xibo shows black background after some hours) but isn’t quite the same - hence separate topic

Running 1.7.3 client and server 1.7.4. Client is Windows 7 SP1, Server is Windows 8.1. Client Browser is Chrome.

The display on the client runs for one iteration and then goes to a black screen. I have to restart the client for it to come back on again. All of our layouts are web pages from a single internal web server, which also serves our 1.6 production environment without a hiccup.

I have captured some information from the Information screen on the client and also the “advanced” client settings, both of which are reproduced below. If more information is needed, I can supply it. Thanks
Display Edit
Settings Profile? Windows
Interleave Default No
Auditing Yes
Setting Value
Collection Interval (seconds) 900
Download Window Start Time 01:24
Download Window End Time 01:24
Enable PowerPoint? 0
Enable stats reporting? 1
Width 0
Height 0
Left Coordinate 0
Top Coordinate 0
Show the icon in the task bar? 1
CTRL Key required to access Client Information Screen? 0
Key for Client Information Screen I
Cursor Start Position Bottom Right
Enable Double Buffering 1
Duration for Empty Layouts 10
Enable Mouse 0
Enable Shell Commands 0
Expire Modified Layouts 1
Log Level Error
Log file path name.
Maximum concurrent downloads 2
Shell Command Allow List
Use CEF as the Web Browser 0
Notify current layout 0
Screen shot interval 0
Limit the number of log files uploaded concurrently 3
Information Screen
LayoutId: 5. Runs from 9/06/2015 12:00:00 AM
LayoutId: 78. Runs from 9/06/2015 12:00:00 AM
LayoutId: 61. Runs from 9/06/2015 10:00:00 AM

media: jquery-1.11.1.min.js. (100%)
media: xibo-layout-scaler.js. (100%)
media: xibo-webpage-render.js. (100%)
media: moment.js. (100%)
media: jquery.marquee.min.js. (100%)
media: jquery-cycle-2.1.6.min.js. (100%)
media: xibo-text-render.js. (100%)
media: xibo-dataset-render.js. (100%)
media: flipclock.min.js. (100%)
media: WeatherIcons-Regular.otf. (100%)
media: standard-icons.png. (100%)
media: weather-icons.min.css. (100%)
media: weathericons-regular-webfont.eot. (100%)
media: weathericons-regular-webfont.svg. (100%)
media: weathericons-regular-webfont.ttf. (100%)
media: weathericons-regular-webfont.woff. (100%)
media: emoji.css. (100%)
media: emoji.png. (100%)
layout: 5.xlf. (100%)
layout: 16.xlf. (100%)
layout: 61.xlf. (100%)
layout: 78.xlf. (100%)
resource: 4d0fdb83ef4c4f4032d04bd5a0fd144b.htm. (100%)
resource: d8e36ec3f233adfc7400ea02c06b1685.htm. (100%)
resource: da4e5a42b96ef47a4d9cf9d45f320da1.htm. (100%)
resource: b8e2da2cc3d5a613777cf33502fa8904.htm. (100%)
resource: bf978c6d9cc62a47b63ba552fd80df4e.htm. (100%)


I see that you have auditing on for that device, could you also turn debugging on (on Report Fault page in your CMS).
Then in logs page you can click on filter then on advanced tab, select only your display (to make it easier to read) and see if(what) errors would be logged there - if yes then please share with us.

On a a little bit side note, if you want to use Chrome then “Use CEF as the Web Browser 0” should be set to 1 - Use CEF should be ticked in display options to be exact.

I think this is likely linked to:

Thanks for the responses.

I get a feeling that the problem might be related to being able to contact the internal web server but if so, it’s inconsistent with our 1.6 production environment.

I created a Layout with the clock and it worked fine. I then added an internal web page and it still worked fine. I then added the page and it caused the display to go black and stay that way.

However it also behaved that way when I had only “known reliable” internal web pages in the Layout. I’ve experimented with changing the amount of time that each web page displays within the Layout but cannot discern any change of behaviour. I’ve followed the steps requested (I think) above and the troubleshooting suggested in “xibo-player-freezes-when-no-wan-connection/2537/10” and have intermittently had the same problem as before.

I have saved some details (2 text files) into a Google Drive as I couldn’t upload them. The drive folder is at

Hope this sheds some more light on my issue. Note that I changed browser back to MSIE (CEF is set to 0)

If the Player isn’t able to connect to the internal web server one time then it looks like it’s causing the player to not see that the media has started running, and so it hangs forever.

I say seems as that’s my black box best guess at this stage.

Once that bug is looked at properly we’ll know more.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.