Youtube stream cant find flash player 1.7.9/1.7.6


As of the last couple of days, all 3 of my signage displays are unable to play a youtube stream, saying that flash player is required to play the video.

I’ve uninstalled and reinstalled Flash (different versions)/Xibo player/.net/rebooted several times but to no avail. Tried different xibo player versions, same result. Also did a fresh install on a new image… same result.

If I view the video in a browser, it works fine. It’s like the program has lost the ability to find flash.

This is the youtube link

Anyone know what I can do? Seems strange that all players went down at the same time.

I don’t seem to have any such issues (granted that I tested it on 1.8.2, but I can do that in 1.7 series as well).

Both embedded html module and webpage module display the streams (and videos) just fine.

Does it work if you open it in IE11?

Are you using webpage module with open natively on your layout or something else?

I believe you have 1.8.1 (perhaps 1.8.2 now) CMS and clients as well, is it the same on them?

Edit: Apparently it could be IE11 problem, for example see here

Snap!! I am experiencing exactly the same issue! For the last couple of days any live stream from YouTube embedded in my layout doesn’t work (I laughed when I saw the same link I use posted here!).

Through IE11 it’s fine but through the signage player, no joy. I’ve exhausted myself with the updates and rollbacks concerning signage players/flash/IE/.net. I’ve gone through IE internet options, compatibility view settings etc… hasn’t made any difference.

I’m using the 1.7 series on Windows 7 64-bit (Server and Client). We have a test setup for 1.8.0 server side using Docker and I have upgraded one of the clients to 1.8.2. The results are identical and frustrating.

Like executiverocker says, it’s like the signage player cannot find or connect with flash.

I really hope you can shed some light on this recent upset.



1 Like

Snap snap, exactly the same here as @executiverocker and @Karl

Stopped working around 3 or 4 days ago. Has anyone got any video news feed that works?

Could you please confirm what Windows version are you using?

I know Karl is on Win7 64bit, I do have similar issues on one of ours win7 laptops here - it works in IE and in Xibo with direct url to the stream/video (same as the url in browser).
Does not work with embed link, embedded iframe or the script that we use for android devices.

Since it stopped working few days ago, for users with various Xibo versions, we suspect that it might be something that either YouTube or Windows update did recently, as for now I don’t really see what that could be.

My earlier post was regarding testing it on my PC (win 10) where there are indeed no issues and every option to embed a video/stream works well - while the same layout is giving me problems on my laptop.

Glad I’m not the only one!! Does it say that Flash player needs to be installed?

The machines using the signage players are Windows 7 32bit. Just glad that it’s something that could be replicated elsewhere.

Anyway of forcing the signage playing to use HTML5 instead of flash?

Windows 7 32 bit for us as well. I uninstalled flash completely in a bid to force it to use HTML5 but no such luck it just came up with a black screen then instead of the message we are all getting now which is:

“The Adobe Flash Player is required for video playback.”

1 Like

Good Morning! So here’s the current situation for me:

Thanks for your advice @Peter. I’ve re-imaged one of our Intel NUCs with Windows 10 64bit build, installed the 1.8.2 client and connected it to our 1.8.0 server in our Docker test environment. Set the default layout using the aforementioned YouTube link and everything works seamlessly.

Because the latest client would not be accepted in our live environment (1.7.4 server) I kicked down the client to 1.7.9. This also works seamlessly. I’ve left it running since Friday afternoon (30th June) and there are no error messages, it hasn’t frozen or stopped working. Great!

So the only noticeable thing to change here is upgrading our operating system to Windows 10. Now that we have a working solution, I will seek to upgrade all NUCs to Windows 10 so that if we decide to stream anything from YouTube on any device, we will not have this problem.

Thank you @executiverocker for raising this issue and thank you bobdigby for your invaluable contribution (sorry, only 2 name mentions allowed for newbies like me!).

Thank you for the details @Karl, it’s interesting, so it would seem that it actually is Windows 7 that is affected by this…I do wonder if there were any recent updates in W7 or in YouTube that are responsible for it - I’m afraid as it is we can’t really do much about it - other than suggest upgrade to W10, which might not be suitable for everyone.

I agree with you completely @Peter. It is hard to pinpoint the actual fault. I did notice that there was an Adobe Flash Player update prior to this issue but other than that I cannot tell what other factors may have been at play. Strangely enough, one of our W7 setup has been behaving itself since 9 this morning. Very weird!

The issue fixed itself some time on Friday. I wonder if Youtube had been tinkering with something their end.

So @executiverocker, all of your players are working as normal? In the meantime I think I’ll check the rest of mine dotted around the place. Thanks for sharing that.

Yep! All suddenly came back into life! Nothing changed our end…

Well then, I’m glad to hear that, it would seem that YouTube indeed made some changes (or some update to W7 in the meantime), in any case, I’m glad that it works for you now.

Yes mine is working again.

Thanks everyone

EDIT seeing as I’m only allowed to enter 3 posts on a thread as a new user

Yep exactly the same! O no YouTube strikes again.

I have not tried anything yet has anyone else found a fix?


1 Like

Anyone elses broken again?

1 Like

As its near the end of term I’m just going to leave it I think and see if it resolves itself like last time.

1 Like

Waow!! Snap, snap and snap again!!! @executiverocker: now it’s the browser that’s at fault! What is YouTube doing??? I have the same issue - saw it yesterday. That was on a W7 machine. I’ve just tested it on a W10 machine and (like in previous posts) it’s absolutely fine - yey!

YouTube might resolve it by the time term starts again. They might orchestrate another incident again. Who knows. But from where I am, we are in a position to upgrade.

I hope you have a solution in place. Thanks for posting again. :thumbsup::thumbsup: