XMR shows connected but not working in xibo1.8rc1 client


I am not able run xmr properly. The client info shows connected to tcp://xx.xxx.xx.xx:9505 but the player doesnt respond to any command or layout change.

OS: Windows 10
Xibo Client : 1.8rc1


Could you double check that it is correctly installed and configured please?

Can you request a screenshot from the player?

Are there any errors in CMS logs?

hi Peter,

I have followed the manual and used 1.8rc1 docker image for cms installation. So i believe i dont have to manually go through XMR and ZEROMQ installation process. It comes builtin. But for some reason i tested on 3 different pcs, the new client doesnt register the XMR address in the config file. It always shows “Empty XMR address”. Also immediately after client installation i get this XMDS error “Invalid character”. I have to manually edit the xiboconfig xml file and enter the XMR address. It shows connected.

CMS : 1.8rc1
Client Player : 1.8rc1
Client OS : Windows 10 home edition

I have tried this on 3 systems. Also the display client never shows logged in even though it is playing content on the screen.


This will always be overwritten when the next RegisterDisplay call is made, so probably not a good idea to do that.

Can you check the CMS settings, display tab and see what has been set in your XMR Public Address?

well dan, that was already crossed verified. Before manually writing, i have closed the player, restarted it and run it for couple of hours. The client shows empty xmr address. I have put my cms ip address along with default 9505 port in cms setting.

It still in same state.


We need to get a log to see what your CMS is sending the player when it calls register. This means you will need to enable debugging on your display and then restart the player application to collect the log in the CMS.

  1. Edit the Display record, go to advanced tab, set a debug until date to be +30 minutes from now
  2. Go to the log page, set the filter to Channel = XMR, Display = your display, Page = RegisterDisplay
  3. Restart the Player application
  4. Refresh the log page and export it to CSV file
  5. Upload the file somewhere and send us the link

I think the CMS is probably sending an empty XMR address, maybe because of a space character in the display settings profile.


It gives nothing blank result.

My fault - I should have typed XMDS as the Channel

Dear Dan,

Please find below link for csv file. It gives invalid character error.

ID	Run	Date	Channel	Function	Level	Display	Page	Message		
3204457A2	c664a23	########	XMDS	POST	ERROR	HOMEPC	RegisterD	Invalid Character Error


Can you try editing your display record and clicking the “Rekey” box on the advanced page and then saving?

I’ve never seen an invalid character error from XMDS RegisterDisplay before - its rather odd. I don’t suppose we can get access to this CMS to see for ourselves?

Xibo 1.8.0
Client OS : Windows 10 home edition


Has worked until now and suddenly came the problem. Screenshots are possible.

Yesterday I had the problem. Could only repair by installing a new CMS

Sorry for the delay, can you enable display audit for a display suffering with this issue?

When I request a copy of the screen I receive this error message.
Any idea what may be configured wrong?
XMR Private Address - tcp: // localhost: 5555
XMR Public Address - tcp: // 9505
Player says XMR Status: Connected to tcp: // 9505

/display/requestscreenshot/1	Player action refused by XMR (connected but XMR returned false).

Xibo 1.8.1 - No Docker

Is XMR and the CMS running on the same machine? I.e. is tcp://localhost:5555 reachable?

Hi Dan

Yes is the same box - Ubuntu 14.04 lts server 64

I reinstall all cms this time using docker with exception for mysql that is external.
The features appear to be working properly, however, the error messages for the XMR remain the same.
I’m using 2 notebooks as players running the 181 client.
I created the reboot command (shutdown / r) but the players do not execute and return XMR false.

The strange thing is that the player says it is connected and has received a heart beat (last activity is up to date). The error message you had before indicates an issue sending between the CMS -> XMR, not XMR -> Player.

Did you have any particular reason for changing the private queue port from 50001 to 5555?

As Dan says, the default ports for the Docker install would put XMR Private on tcp://localhost:50001 or tcp:// depending on your exact setup.

As you’re using external MySQL, we wouldn’t have set that value for you as we do on a fully local install, so I expect all you need to do is change that setting.