XMR connection failed. ZMQ: Protocol not supported


When I try to request screenshot of my display, it returns error on the logs… Please see the attached image.

Player action connection failed. E = XMR connection failed. Error = Failed to connect the ZMQ: Protocol not supported

I hope any one could help me with my problem,


This is related to your other issue? ZeroMQ is not working

Have you configured your public/private addresses in the Display tab in CMS settings?

Yes Dan, this is related to my other thread, but i already run the xmr.phar. now when I request a screenshot it will successfully request.

but when I see the log, it is return ZMQ error.

By the way, here is my display settings.

should I change this configuration? Please advice.


You seem to be missing the public XMR address?

it should be something like:
tcp://domainName:9505 or tcp://IP.address.:9505

From your earlier topic I believe you have that in the your config.json already, but it should be provided in the Settings -> Displays tab as well.


Should I leave the XMR Private Address with the current value then?

I have added the xml public address,

but it returns the same error in the log.

From your other topic:

You’ve configured XMR to listen on tcp:// and publish on :9505 - this means that your:

  • public address is: tcp://
  • private address is: tcp://

But you have put tcp://localhost:5555 as the private address in your CMS settings.

Should this be ok dan?

If that matches what you’ve configured for XMR - then yes :slight_smile:

If yes, and it still doesn’t work - lets see the output of XMR in debug mode. Adjust the debug property in config.json and restart XMR. You should get some extra output

Hi Dan,

After updating the Private and public address… It didn’t work. when I try to request a screenshot, it will just load and not closing the dialog box… Also I already added a debug property on my config.json, but I didn’t get any errors on the log…

By the way, can I pm you the access to our CMS so that you can have a look and feel free to test it…


By the way, here is the screenshot when I try to run xmr.phar

The only thing I can think of at this point is to run XMR from source code, and enable more logging in it to find out what is causing the segmentation fault.

The source code is here: https://github.com/xibosignage/xibo-xmr, you can get a zip or git clone of that and drop it in a folder (i.d suggest /home/nvdigi5/xibo-xmr). Copy your existing config file into the new folder and you can try to run xmr by:

cd /home/nvdigi5/xibo-xmr
php index.php

We can then add some more logging to index.php below line 15.

ini_set('display_errors', 1);

Thank you for this dan, I will try it…

1 Like

Hi Dan,

I have follow your instruction and run it on my server… Also I have also updated my document root to point now in web instead of public_html…

By the way, when I try to run xmr on my server… It will now have information that it is starting and listening to my cms… also, when I try to request screenshot, it has xmr info with and json object on it. Please the screenshot…

However, I can’t see any screenshot being uploaded on the display on my cms… also, I try commands like restarting the player with this command taskkill /f /im XiboClient.exe and rebooting the pc using this command shutdown /r /t 0 , it will just add to the xmr info that there are a request, but it doesn’t do anything… Also turn off the firewall already on my player computer to make sure there wasn’t no blocking on accessing my cms… but it doesn’t work either…

I know, I am getting close on this… I can feel it… Thank you in advance for your response for this issue. :slight_smile:

Best Regards,

Hoping for your response for this dan…


Sorry for the delay, it has been a busy few days with 1.8.2. It is interested that you have a working XMR from the repository - I can’t immediately explain that.

Now that XMR is working (logging requests from the CMS) and also sending heartbeats, you can use the player information screen to show whether or not it has been able to connect to your XMR service on the IP shown for publish.

You can also use the column selector on the CMS Display page to see if “XMR Registered” has been ticked, which will happen when the player registers its XMR channel (identifier).

Yeah… That’s interests me too… that XMR is now totally working using the source code.

By the way, How can I show the player information screen?

However, I think it is already XMR Registered. Please see the screenshot.


Hi Dan,

I believe this is the player information screen… Please see the screenshot below…

As I check, there is a few error, but I don’t think so it is related on the XMR… Also the the XMR status is connected…

Your CMS address should be http and not tcp - the XMR address is tcp (which is already correct)

My CMS, address is already pointed to http://jmdev.nvdigitaldisplays.com. sorry, that was wrong screenshot dan…

Also, it doesn’t get the screenshot or listen to any commands…