Xibo on Android cannot stream RTSP

Hello everyone,
I am sorry asking the same old question. But when I tried to stream rtsp video from the cctvs, it doesn’t work and there is this error log on android player(Please refer to the image).

Android player version is Xibo 2 R207
CMS Version is 2.3.7

Hi Jet_Stream,

The stream appears to be a codec that Android cannot display. Are you able to ensure that the stream is compatible, ie webm or H264?

Kind Regards,


Hello Frazer,
The original source of the stream is from a CCTV. According to the web console of the cctv, the stream is H264. Is there any other way to check the codec ?
I am planning to stream multiple CCTV using rtsp. Currently I’m testing using an android phone(Xiaomi Mi 8 Lite). I needed to see if RTSP streaming is work on android player. If its works, I’m going to buy an android tv for this.
Could it be the problem of android device ? Is it because I’m testing on a phone ?

Android is Android.
I had the same issue with Axis and Bosch camera’s. You need to configure the output stream or use a correct RTSP streaming URL where you request a specific codec.
I have learned that H264 is acceptable and others are not working.

Doublecheck if the streaming codec for live view is H264.

Thank you for your answer.
I will check if the output stream is in correct codec.

Hello again,
The video streaming codec is H.264, I doubled checked it. But still Xibo android wont play the video.

Just a doublecheck…
Can you open the streaming URL with Windows Media Player or VLC?

Yes, the streaming can be played smoothly on VLC media player. I haven’t got to test on Windows Media Player yet.


I believe the issue is that you have a login/password in the url, I did try to get a fix for this under the Android/Linux client, but was unable to supply at the time a publicly available camera which uses login details as part of the url for support/development to work with.

I’ll be revisiting this issue again shortly, and will be in a position to provide development with a publicly available camera, so hopefully they’ll be able to sort this issue out once I’ve done that.



Apologies please ignore previous post, it states elsewhere that Android client should support that syntax.



Yesterday we tested 2 different Axis IP camera’s. Older one had no problem streaming RTSP but newer Axis IP camera seems like the streaming is OK, but Android player can’t handle this. Already tried to change streaming RTSP URL in order to change codec but that is not working.

Maybe it can help you? search for RTSP options for your security system.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.