Xibo (docker on Ubuntu 18.04) update from 2.3.10 to 3.0.0-rc3 stuck on db migration

CMS Version
2.3.10 ->3.0.0-rc3

Installation Method


Operating System

Ubuntu 18.04

Hi there,

I just tried to update from 2.3.10 (docker install on ubuntu 18.04) and get stuck on the "The CMS is temporarily off-line as an upgrade is in progress. " screen. I checked the logs of the docker web cms. It starts off normal, but then I get:
cms-web_1 | up 20200130165443 2020-03-06 11:11:03 2020-03-06 11:11:03 CountdownModuleAddMigration
cms-web_1 | down 20200311110512 AddIsDrawerColumnMigration
cms-web_1 | down 20200311110535 CreateActionTableMigration
cms-web_1 | down 20200319093235 ChangeInterruptLayoutMigration
cms-web_1 | down 20200401121544 AddSystemUserSettingMigration
cms-web_1 | down 20200407143200 AddCodeColumnToLayoutMigration
cms-web_1 | down 20200422101006 AddDataSetRowLimitMigration
cms-web_1 | down 20200427085958 AddReportScheduleStartEndMigration
cms-web_1 | down 20200530103029 DisplayRemoteLinksMigration
cms-web_1 | down 20200604103141 CommandImprovementsMigration
cms-web_1 | down 20200612141755 OauthUpgradeMigration
cms-web_1 | down 20200720092246 AddSavedReportSchemaVersionMigration
cms-web_1 | down 20200916134817 RemoveOldScreenshotsMigration
cms-web_1 | down 20200917140227 DisplayGroupCreatedModifiedDates
cms-web_1 | down 20201007080829 AddFoldersMigration
cms-web_1 | down 20201007093511 FeaturesMigration
cms-web_1 | down 20201025153753 RemoveOldPermissionSettingsMigration
cms-web_1 | down 20210105105646 AddMcaasScopeAndRouteMigration
cms-web_1 | down 20210113134628 EnableUserSharingFeatureOnUsersGroupMigration
cms-web_1 | down 20210201150259 UserOnboardingMigration
cms-web_1 | down 20210305131937 FixDuplicateTagsMigration
cms-web_1 | down 20210407111756 RemoveReportNameColumnFromSavedReportMigration
cms-web_1 |
cms-web_1 | We will upgrade it, take a backup
cms-web_1 | mysqldump: Error: ‘Access denied; you need (at least one of) the PROCESS privilege(s) for this operation’ when trying to dump tablespaces
cms-web_1 | Running database migrations
cms-web_1 | Phinx by CakePHP - https://phinx.org. 0.9.2
cms-web_1 |
cms-web_1 | using config file .varwwwcmsphinx.php
cms-web_1 | using config parser php
cms-web_1 | using migration paths
cms-web_1 | - /var/www/cms/db/migrations
cms-web_1 | warning no environment specified, defaulting to: production
cms-web_1 | using adapter mysql
cms-web_1 | using database cms
cms-web_1 |
cms-web_1 | == 20200311110512 AddIsDrawerColumnMigration: migrating
cms-web_1 | == 20200311110512 AddIsDrawerColumnMigration: migrated 0.2561s
cms-web_1 |
cms-web_1 | == 20200311110535 CreateActionTableMigration: migrating
cms-web_1 |
cms-web_1 | In PdoAdapter.php line 134:
cms-web_1 |
cms-web_1 | SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'ownerId
cms-web_1 | ’
cms-web_1 |
| migrate [-c|–configuration CONFIGURATION] [-p|–parser PARSER] [-e|–environment ENVIRONMENT] [-t|–target TARGET] [-d|–date DATE] [-x|–dry-run]
cms-web_1 |
cms-web_1 | Importing ca-certs
cms-web_1 | cp: can’t stat ‘/var/www/cms/ca-certs/.pem’: No such file or directory
cms-web_1 | cp: can’t stat '/var/www/cms/ca-certs/
.crt’: No such file or directory
cms-web_1 | WARNING: ca-certificates.crt does not contain exactly one certificate or CRL: skipping
cms-web_1 | Setting up Quickchart
cms-web_1 | Configuring Maintenance
cms-web_1 | Removing web/install/index.php from production container
cms-web_1 | Starting cron
cms-web_1 | Starting webserver
cms-web_1 | AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using Set the ‘ServerName’ directive globally to suppress this message

I assume it might get stuck on the Duplicate column name 'ownerId '. Is anyone else having this issue?

If anyone else is having this issue, I managed to resolve. My problem was due to the mariadb settings which in this rc3.0.0-rc3 seem to be different (new version of mysql) from our current version 2.3.10
I edited the docker-compose.yml file and added one line to the cms-db section. Just above (and inline with) mem_limit:1g I added the line

This solved my problem completely. The dump from 2.3.10 got converted correctly and is now running.


Hello Im having the same issue as you but when i add the line i get this error:

ERROR: yaml.scanner.ScannerError: while scanning for the next token
found character ‘\t’ that cannot start any token
in “./docker-compose.yml”, line 12, column 1

This is how i add it:

version: “2.1”

image: mysql:5.7
- “./shared/db:/var/lib/mysql:Z”
mem_limit: 1g
env_file: config.env
restart: always

like you mention i add it just abobe and inline with the mem_limit.

can you please help and thanks


I forgot and i use tabs to add the line while i need to use space instand,
thanks a lot for your post it’s help.

Hi Guys,

I get the same error as TechLearning_Net…

Further I get the error:
cms-db_1 | 2021-06-25T12:17:45.776215Z 5 [Warning] InnoDB: Table mysql/innodb_table_stats has length mismatch in the column name table_name. Please run mysql_upgrade

I tried this and get the error that cms can’t connect do mysql.sock… I don’t know …

Please help

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.