Xibo client wont download any content from CMS

My Library path is fully qualified … but my display status shows as “display is out of date but has not yet checked in with the server”. what does it mean?

It means that your player was unable to connect to the CMS since there were some changes made.

If there is no connection issues, then it will try again next collection interval, if this status persists then it would imply some connection issues - ie your player can’t reach CMS therefore can’t download content/schedule from it.

Client found response content type of ‘text/html; charset=UTF-8’, but expected ‘text/xml’.
The request failed with the error message:

Deprecated: Automatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set 'always_populate_raw_post_data' to '-1' in php.ini and use the php://input stream instead. in Unknown on line 0

Warning: Cannot modify header information - headers already sent in Unknown on line 0
<?xml version="1.0" encoding="UTF-8"?> <?xml version="1.0"?> 601465942200000146602440000010000010IBottom Right110001error200031NOVO-pc0


In this case, please open php.ini, find this line
always_populate_raw_post_data set it to -1 and make sure it’s not commented out (no ; before that line in php.ini)

After that, please restart your web server.

yess !!! its working now … :grin:

there are 4 to 5 thing that have to be changed in php.ini file i had done it while installing cms … i dont remember it now could you please tell me so that i can note it down.

Are you thinking about upload limits etc?

hey now im facing a new problem … display status shows as “client is downloading files” but it does not play the scheduled layouts it just displays the default layouts…i tried changing the default layout to the one i scheduled it works fine so my layout is valid… what could the problem be?

Are date/time settings on the CMS(web server) and on your PC with Xibo for Windows the same?

If it works as default layout then as you say layout seems to be valid, but perhaps there is something wrong with date/time and that’s why schedule is not quite working.

You can show us screenshot of status window on your device (when it has problems displaying this layout from schedule).

My layouts are valid but they are not playing on the client… i tried deleting the layouts and created 2 new layouts but now even if i set it to default its not playing.

16-06-20 10:39:56

                                            <errormsg>unlink(C:\Xibo-Library\temp/d969640dd686d9a34efea2b8896490e0.jpg): No such file or directory</errormsg>





                                            16-06-20 10:39:56

No such file or directory





And now im not even able to preview the layout in browser it just shows the black backgrount :cry:

Have you configured the Player and the CMS to use the same library directory?

If so, you mustn’t do that. The Player needs it’s own library. If you try and run it in the CMS library directory it may delete content.

You should configure it to use a blank directory of its own, and then re-upload your media items to the CMS and delete the old broken items.

A post was split to a new topic: Datasets preview but won’t show on Player

My layout preview page is black screen,But when I’m going to set it back,Set up “off",It can be previewed again。

  • List item

May I ask where I have not set up,Thank you!

My environment is WINDOWS10,The way I use WEB,xampp5.6,The PHP extension zeroMQ is also installed,XMR is also started,I can’t find the problem now is that I’m not configured well

If you have File Download Mode set to “Apache”, then you need to have the X-Sendfile module installed on Apache, and configured appropriately.

If you don’t, then that setting must be set to Off.

You can see how to configure X-Sendfile in the Docker container configuration here:

Clearly you’d need to adjust the path to match whatever you’ve configured for your CMS library directory on Windows.

X-Sendfile doesn’t ship with XAMPP. You have to download and install it manually.

Your XMR isn’t configured correctly either.

Private port looks good, but you want the public port listening to “tcp://*:9505” or at least one external interface, otherwise the Players won’t be able to connect to it. You’ll also need to allow it through any firewall.

You need to arrange something to have that run automatically every time your server starts up, and restart should it crash or stop running.

A post was split to a new topic: Problem with downloading content 1.8.10