WebOS - Could not connect to the CMS

Hello people !

I have a full working Xibo CMS server (with Docker under Ubuntu server) and 38 windows players attached to it and working great.

Now my company wants me to test Xibo for WebOS to simplify the management and installation so I’m testing Xibo for WebOS on a LG 43SM5KE screen.
Our screens supplier lended us this screen and I downloaded Xibo IPK and installed it. The problem is I cannot connect to the CMS after entering the address and the CMS key.

The address is in httpS but with a certificate signed by our company (we have an internal servel). Could that be the problem ?

And the CMS secret key is a bit long too : 32 chars. Could it be the problem ? (But it works fine with all my other Windows players)

The message I have is “Could not connect to the CMS” and on the bottom left of the screen appears a “[object Object]” string.

Can you help me please ? I dont’t know what to try. :smiley:

Having the same problems here. On first startup everything was fine. After a while the Xibo splash screen show only on the half size of the screen and after a short time loading will be shown and nothing will happen! Nothing works instead of begin from the scratch! You could try to re arrange some layers and save sometimes it works sometimes not. LG and Webos doesn’t work well on the last software for both side! We have 3 LG Displays which are supported in the list but they won’t work with the latest software release. We hope do get a solution within the next weeks. We have attached some screenshots. For know we have tried a full factory reset with different player releases and a new installation of Xibo itself. The Xibo server is on 1.8.12.!

Well here on first startup, I can’t even connect to the CMS server to register the display.

I have this message when I try :

And by the way, my CMS version is 1.8.9 (How can you be on 1.8.12 ? The latest is 1.8.11)

Thanks for your help.

The Display will not accept self-signed certificates, which would explain why the connection is being rejected.

You will need to use a certificate that is not self signed to resolve the issue. Some models of LG Display support importing your certificate into the Trust Store. The E series Displays should have an option to do this in the menu.

Many Thanks.

Hello Dan,

Many thanks to you :smiley:

Now to resolve the issue, it may be a little off-topic but I’ve looked around how to import certificates to the LG screen and I tried to do so with no success.
In fact the Xibo server has not a self-signed certificate but a certificate signed by the certification authority of our organization. Do you know what files I should import (and how) to this screen ?

Big thanks for your help.

You would need to import the CA root certificate for your organisation in to the screen for certificates signed by that CA to be recognised.

Thank you Alex.

Right now, I can’t do this because when I try to, there’s a message saying it can’t find the (certificate) file on the USB stick.

I opened an issue with LG France to help me and they couldn’t help me. They asked to LG Korea, now I’m waiting an answer. I’ll post it here when I have it.

1 Like

Hello all !

I had an answer from LG Korea : I managed to import our CA root into the screen.

Not very Xibo related but it may help some of you :
To import your CA root you have to have it in X.509 (PEM) format in a *.CRT file
You have to put in on a USB stick but not at the root of it. First create a folder and subfolder named LG_MONITOR/CERTIFICATE and then you put the *.CRT file into that subfolder so that the LG screen can “see” it and import it.

Now I have a Xibo related problem :
After setting the CMS address and secret key, Xibo still can’t connect to the CMS. I have a toast message saying it can’t connect and then a black screen with [object Object] on the bottom left :

I am stuck again but this time it’s not because of the certificate :confused:

Can you please help me ?

I have to say that our CMS is fully functionnal with about 40 Windows clients that contact the CMS (V1.8.11, Docker, on Ubuntu Server 16.04) with no problem and the (trial) licence is valid.

Thank you.

Thank you for providing the instructions for importing CA certificates into your webOS Display, this is very helpful and benefits all of our webOS users.

Can you provide a new Status screenshot for this Display?

I can also see that you uploaded some screenshots on another post, which I have linked below:

According to those screenshots, you are using http instead of https. Can you confirm whether you are able to connect using http at the beginning of the CMS URL instead?

Many Thanks.

Hello Dan,

Sorry to reply one week later but I had no time this week. And thank you for your help :+1:.

The story about Xibo at our company is the following. We have one production server here, that works in httpS with almost 40 screens (and even video walls) and everything works seamlessly.
We have a Ubuntu server V16.04 that runs Xibo with Docker V1.8.11.
All our displays until now are old laptops that we recycle when users stop using their computers (except for the video walls). We reset them and install Xibo (Windows version), plug them to a screen and hide them behind it.
Now we have a place where we can’t hide the laptop behind the screen because there’s no room behind it. Our screen supplier lent us a LG with webOS on which we can install Xibo to see if it fits our needs.

I tried to add the display to our Xibo production server but I didn’t know how to import the certificate then (until LG replied and explained the way to do it).

While I was waiting LG’s answer, I tried with a Xibo “test” server (related to my other post) and could add the display and send some layouts and do the testing.

Now that I know how to add the certificate I want to add the screen to our production server again but I have an error message.

Here’s what I’m doing :

As you can see, I themed Xibo (the X at the end of CampiX stands for Xibo :wink: : Campus - Xibo)
What’s important here is the httpS so you can see it’s certified by our CA.



Evething works fine with our Windows displays, we have several users/user groups, displays/display groups :


Now, let’s configure the webOS screen.
First of all, I reset the screen to the default parameters.

Then I choose full setting

I configure the NTP server with our own

And proceed to SI Server Setting

The first thing I do is import the certificate so I go to the menu and choose settings

Choose the file (there’s only one)

After that, the screen reboots itself and I resume the installation seeing the certificate is here

I fill the location of Xibo for webOS R15 (you see http but that’s because our Xibo server has also a distinct apache web server on port 8080 to serve web content, and that’s where I put the IPK file)

It’s installed !

Now I launch the app for the first time

Fill in the fields…

… but : Could not connect to the CMS ! :worried:

I send you the status info if you can see if there’s something weird

There’s on thing that seems not good to me in the logs but I don’t know how to handle it :

Also, Itried to enter an incorrect CMS key just to “see” what happens (same message or “incorrect key” message)

But it’s just the same. :cry:

Can you help me try to fix this, Dan, please ?

Thank you.

Thank you for all of the information you have provided. I can see in the screenshot under where you have written:

Now I launch the app for the first time

That the Network setting suggests you do not have a network connection? Can you confirm that the Display is connected to the network?

Many Thanks.

Yes indeed, I have no problem when I put the Xibo test server address. I can see my layouts play (even YouTube videos and weather widgets).
Besides, the IPK app is downloaded from the web server and the time is set through our ntp server.
So yes, I have network connectivity.

Thank you for confirming that the Display does indeed have a Network connection.

A test environment has been set up so that we can look into your issue further. As soon as I have more information for you, I will let you know. If you have any further information you would like to pass on, feel free to let me know.

Thank you for your patience

Many Thanks.

So it looks like the screen LG have directed you to is to load in self-signed certificates only (not additional certification authorities which should be trusted generally).

We’re speaking to LG to find out how you should load in a CA.

Thanks a lot Dan and Alex, besides loving Xibo, I really appreciate your support. The way you handle all the users problems is really professional and great.

Unfortunately I cannot keep the screen much longer because our supplier lent it for testing purposes and I have to give it back. So I won’t be able to answer you if you have some questions.

However, if LG gets back to you with the answer on how to load a CA into the screen, can you please reply to me and I’ll ask if I can have the screen back again to continue the testing ?

Also, I have a half off-topic question, I am trying to have a screen with an integrated android player instead of webOS. Do you know if android allows importing CA certificates ?

Thanks again for your help.

We are trying to test xibo with webos but we could not connect with the cms
Attached files with information of the issue
Please, could you help us?

Apologies for the delayed reply to your issue, thank you for the screenshots of your Status page. Can you confirm what Version of CMS you have installed and whether it is a Custom or Docker setup?

I noticed that you are running Firmware Version 04.02.20 on your SM5KD Display, I would first recommend upgrading this to a newer version of the Firmware, we would recommend 04.03.10 at the time of writing this reply.

I also noticed that in the field named Content Management System it simply states http://. Is this because you have edited the screenshot so that the full URL for your CMS is not shown? If not, can you confirm that you have entered the URL of your CMS and Secret Key correctly on the Check License option in the Player?

There also appears to be 20 concurrent failed connection attempts which would suggest that something, either connection or configuration related is stopping that Display from contacting your CMS.

I would first recommend checking the URL and key of your CMS are being entered correctly into the Check License option on the Player. Once you click Connect you should receive a message confirming that your Player is awaiting Authorisation in your CMS or an error message confirming that it was unable to connect. Can you provide a screenshot of that message please? I can understand that there may be sensitive information on that screenshot so feel free to send it to me privately if you prefer.

Many Thanks.

Hello, i need helping for upgrade firmware my 43SM5KE because i not recognize correctly my usb key. i cant ugrade my White label webOS ipk file. I cant upgrade my boot screen on tv. I try several usb with several size and several formatting method but Nothing.
My model name: 43SM5KE-BJ
webOS version:4.0.1-18
S:W version: 03.01.70

i see my model in :http://partner.lge.com/de/portal/main/main/fowardMenuUrl.lge?_MenuId=210099&_MenuLevel=2&_MenuParentId=210089&_SuperCategoryCode=&_searchKeyWord=&pageName=http%3A%2F%2Fpartner.lge.com%2Fde%2Fportal%2Fdownload%2Fdownload%2FretrieveTechnicalDataDetail.lge%3F_MenuId%3D210025%26contSeq%3D0005920963&needReload=&siteCountryCode=de

But i need confirm with you if have other source of firmware update. Thanks you . best regards

Thank you for your message. regarding Firmware, below is a link to the Firmware for the SM5KE series of LG displays.


Please note that this is the recommended Firmware version at the time of me posting this message. Our Firmware matrix is the best way to confirm if your Firmware is the recommended version:


If you are finding that your USB device is not being recognised by your LG display, you will need to contact LG for further support with this. I have also included a link to our Xibo for webOS Player upgrade guide for more information on how to upgrade your Player:


Many Thanks.