Ubuntu 16.04 and php 7. Blank screen on web page

Upgraded my linux box to Ubuntu 16.04 which includes php version 7.
When I go to the web page, I just get a blank screen.

Downloaded and installed the latest version and get the same result.

Suggestions ?

FWIW… I had a similar problem with moodle… that went away when I installed the latest rev.

Quick search of the community…


Tx for that…

Pity… as I cannot go back… I have other stuff hanging off that machine…

Those remarks were in April. Are we any closer ? Or would trying 1.8 Beta at least get me going again.
I have a very simple setup with only 1 screen…


Have you looked into the possiblility or running both 5.6 and 7 at the same time? Some configurations can support this.

I can’t answer the question as to if Xibo is closer to running on php 7 or not, as I am not part of the development team. I think the main problem is dependencies. As dependencies support php 7 Xibo then will in turn also be able to support php 7.

Thought of it … but it seems that /etc/php.conf (whatever) is a link to 7… so am scared to try in case I break the rest of my server…

Tx anyway… let us hope the devs can point us in the right direction…


1.7 is never going to run on PHP7. There’s too much that would require change to support it.

1.8 will, but at this time, some of the libraries that 1.8 uses are still not supporting PHP7, so we will have to wait for them to get fixes in place before our code can run there.

In the interim, you could consider running 1.8 series in Docker containers on your machine.

Tx for the quick reply.

Downloaded the 1.8 beta from Github… just the source…
The main directory did not contain an index.php and I tried to get “cute”… but it all turned
into a train wreck ( to mix metaphors :slight_smile: )

I saw the docker stuff… My feeling was it force Xibo to run on port 80 and trash my intranet site ?
i.e. sort of designed to run on virgin hardware…
Does the docker isolate xibo from the underlying php ?
I was running Xibo as an apache alias http://intranet/Xibo

But these are all newb questions…

Certainly willing to have a go if you can point me in the right direction.

Tx again

1.8 is one of the newer style of PHP applications - where there’s a “web” directory, which contains index.php, and that is the point that the webserver must serve as your document root. The directories below that need to remain there, but they aren’t web servable. This greatly increases security since library code isn’t exposed to the network.

If you download the source yourself from Github then there’s a load of work that has to be done to bring in application dependencies. You’re much better off downloading a release tarball as it has all that work done for you.

Yes Docker brings its own PHP environment - everything Xibo needs to run pre-configured for you.

By default it runs on port 80, but you can configure launcher to bring it up on any port you want. Once you’ve done that, you can either address it directly on that port, or you can setup your main Apache instance to proxy through traffic to it.

When we’re closer to the final 1.8 release, you can expect some documentation on setting up a Docker based setup and migrating a 1.7 series install over to it. launcher doesn’t support a migration at this time.

Ah , tx

Am trying the tarball.

Any idea of when 1.8 will be in final ? I notice you advertising for code cutters… :slight_smile:

Yes… I know I am bludging…


1.8.0-rc1 in the next few weeks. 1.8.0 final depends entirely on what issues arise once people have spent time using that.

Sounds like me then. :slight_smile:


Well. that was interesting… I learnt how to set up virtual hosts in apache… another entry in my CV :slight_smile:

downloaded the tarball from here

Set up my virtual host as

ServerAdmin webmaster@localhost

ServerName xibo.e4182s01.schools.internal

ErrorLog ${APACHE_LOG_DIR}/xibo.error.log
CustomLog ${APACHE_LOG_DIR}/xibo.access.log combined

DocumentRoot /mnt/d2/xibo/web

<Directory "/mnt/d2/xibo/web">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Require all granted

Copied my settings.php over to try, and it complained… Deleted the settings.php file.

It came up with install screen… natch… will start again…learning how to do things was the time consuming part.

It liked my requirements. Except for zeroMQ. Later…

Clicked the next button and got …

The requested URL /install/2 was not found on this server.

Clicking on the re-test button on the main screen could not find /install/1 either.

Suggestions ?.. or am I better waiting for rc-1

1.8 won’t work with PHP 7 as it stands, so I’d say you need to wait for us to announce support for that :slight_smile:

The reason the URL isn’t found is your AllowOverride None line
It’s preventing the .htaccess file we ship using mod_rewrite to handle URL rewriting.

The Docker image comes with all this preconfigured. If you want to try and do an upgrade, then your settings.php will need to go in, but under the web directory. I’d guess it’s erroring because of the libraries in the stack that don’t support PHP 7.

Perhaps in the interim, you’d be better spinning up a new server with an older Ubuntu version to host Xibo 1.7.9 on until you have something else in place.

had a play with docker… very Interesting … but it seems to want to install php5 and a whole bunch of other stuff duplicatiing what was already on my (production) server… and I had issues with the gpg on a virtual machine and it all got a bit scary and hard.

Took your advice and cranked up a spare box with Ubuntu 14.04.

Like 1.8rc a LOT.

Please rush the php7 capable stuff. :slight_smile:

Appreciate your help.

Our stuff is PHP7 capable! It’s the libraries that the CMS uses that require PHP5 for now. As soon as those update, we’ll be able to support PHP7.