[solved] Xibo 1.8.0-rc3 Ticker Template does not save


I have freshly installed xibo 1.8.0-rc3. I have made a new dataset and a new layout and I want a ticker to display the content of the dataset in the layout. Now my problem is, if I open the ticker and set it to display the dataset, set a duration, the name and other things and edit the template with the “available substitutions”, everything is correctly saved, but not the template. The template is empty every time I close the ticker and reopen it.
It worked in 1.7.9 and I have no idea what is wrong nor where to search for it.

Thank you for your report.

It’s a known issue and it will be fixed in the next release, please see for more details https://github.com/xibosignage/xibo/issues/1054

You should be able to patch your CMS by yourself using Dan’s commits and changes he made to /lib/Widget/Ticker.php

Thank you for your quick reply.

Where do I find /lib/Widget/Ticker.php ? I have installed xibo with docker and I guess it is inside the image. Can you point me to a manual how to make changes to the file?

EDIT: I found it

Just please be careful when you change things there - perhaps take a backup of this file to be safe :slight_smile: