[SOLVED] V4.0.0 - Some Bugs + ZMQ Problems | ZMQ for PHP 8.2.10 NTS | OpenSSL 3 Legacy Setting to Windows Server IIS

I’m using a custom installation (IIS/ Windows Server) of a CMS migrated from V3.3.7.

1 - Any attempt to make changes in the CMS fails, reporting an issue with the PHP version (which is incorrect).

2 - I’m still having some trouble with ZMQ. I’ve tried various versions of PHP 8, but no luck. Can you give me a tip on where I can find the correct .dll file for ZMQ for PHP 8.1/8.2? I’ve already tested the ones from the link below without success: Releases · stijnvdb88/php-zmq · GitHub"

3 - For some reason, the “Verify Modules” button is not displayed

1 Like

This error is raised by composer auto-loading when the PHP_VERSION_ID is lower than required for PHP 8.1; which is 80100.

Funny though, we use phpversion() to output the message in report fault. And why would it only be on change - autoload.php is always included (it has to be).

When you say “on change” do you mean any change?

Sorry I would have pointed you to the ones you’ve already found. What about those ones doesn’t work?

It isn’t needed anymore as all of that stuff is automatically managed.

I mean that the CMS doesn’t allow me to make any changes in any form, such as update a display name, update a layout name, etc etc etc… All the CMS is that way. The message appears, loads endlessly, and the change/update is not applyed in the database
Also… I put the CMS in test and debug mode, and nothing about it is displayed in the logs

Yeah… they didn’t work for some reason in the CMS… but I didn’t have any installation errors
Even IIS accepted it normally:

@dan i found out the reason for the “Application Message”
I forgotten the “PUT” and “DELETE” verbs on the web.cofig file :wink:

When i add them, the error was not displayed anymore.

Now i’m trying to solve the problems that remains, as the ZMQ one.

1 Like

RSS tickers (migrated or not) cannot consume images. (I also tested this on the besta testing CMS).
The images came as “null”
This is a screenshot from my CMS

And this is a screenshot from the beta testing cms (Layout ID 67, called “RSS Ticker Image”):

Interesting RSS issue - I see that the feed in question uses media:content to supply images, which I suppose you had to parse in v3 with a [media:content|image] variable?

Pending that extra info, I do think it shouldn’t show a broken image if it doesn’t have an image returned, so I have created an issue for that:

I also tested an RSS feed that has an ‘image’ tag,
And still, the layout is not able to interpret it…
Print below of the same layout I mentioned in the beta testing CMS (the same thing happens in my local environment)

Understood - issue created to improve:

It seems like I won’t be able to resolve this issue…
These versions of ZMQ are not available for PHP 8.x NTS, which is used in IIS + FastCGI on Windows Server.
Now I’m facing this problem, I’ve searched the entire internet, but I haven’t found anything.
I don’t know what to do about it for now.

1 Like

Hmm that is unfortunate.

The builds there are for TS I think, mentioned in this issue: PHP 8.1 windows builds? · Issue #223 · zeromq/php-zmq · GitHub.

There are some build instructions in this commit: added build instructions for windows · zeromq/php-zmq@b38670d · GitHub. I am not sure if they will help.

Hello Mr. Paulo,

You can click this link: Websocket , Zmq and PHP 7.4 - EspoCRM Open Source Community Forum
You can register in this forum and you can communicate and ask Mr. Ceonello, maybe he can help you.

Best regards,



The ZMQ issue is a big problem, can’t find any NTS binaries that work with PHP 8.1 or 8.2.

I will try to generate this manually here, and if I succeed, I will make it available for everyone.
I will try to make this work during this week.
However, I recommend not to have too high expectations for this solution, and if possible, try to compile it on your own as well.
I will keep you updated here on what I manage to accomplish!


I tried my best so far… but that task did not get well guys. I think that i will not be able to solve this.

Just did it guys:


But it dosen’t work for me… still the same:

Test it, please!

---------------------- ignore this, please.

Hello Mr. Paulo,
I apologize in advance, I want to ask why the libzmq.lib file is not in the link you gave above?
I have downloaded and opened the file from your link but there is no libzmq.lib file (see image below):

Best regards,


Yeah you right. I’ll keep tryng!



Good news guys!
I was able to solve that!


Now it’s working :smiley:


Back again:

XMR are not working :frowning: