Screen Saver Does Not Present As Separate Display (and Other Issues) (1.7.8)

Separate Displays

I installed Xibo 1.7.8 on my Win10 desktop and configured the main client. Then I enabled the screensaver and configured its settings. (To note: the desktop config and the screensaver config point to different storage directories.)

On my Xibo backend, they show up as separate displays. Each can be configured with separate layouts/settings if I choose.

However, when I did the same installation process on three other Win10 machines, after configuring the main and screensaver clients, they do not show up as separate displays in the Xibo backend. All show up as the same. And, oddly, all show up as active, all the time.

WatchDog & Screensaver

One of the displays referenced above, when in screensaver mode, will randomly activate the desktop client (and the watchdog), which then overrides the screensaver. This makes it impossible for users to just walk up to the workstations in question, wiggle a mouse, and be presented with the desktop. (End-use: Timeclock workstations on a shop floor. When not being used to clock into jobs/shifts, the intention is to have the Xibo screensaver display relevant shop info/announcements.

Screensaver Background Issues; Temp Files, Not Refreshing

On occasion, all of my screensavers will have the background “bleed through” regions, ruining the aesthetic and making it difficult to read. This isn’t a problem on the desktop client, and even when “Preview”-ing the screensaver in the Win screensaver settings window; it only happens on occasion when the screensaver is triggered by the system.

The “fix” I’ve discovered is to erase the storage directory for the screensaver client; this forces a download of the display layout files again, which makes the issue disappear for the time being.

Because I’m a new user and can only put one image in a post, I’ll follow up with more images in replies… .hopefully it’ll let me do that.

Here’s the “bleed through” issue I’m referring to. Again, this is only happening on an active screensaver… and is fixed when one manually clears out the temp file storage directory.

In the ScreenSaver Preview screen, you can see the “bleed through” issue isn’t a problem.

Separate Displays

Most likely fix would be to adjust the Display ID in player options
Please see I added a new Player and it went straight to "Display is active and ready to start"? I'm using an imaged/cloned version of Windows and all my Players show up as the same display in the Xibo CMS?

WatchDog & Screensaver
In this case you might consider disabling watchdog
Please see The Windows Player automatically restarts itself / Windows Player Watchdog

Screensaver Background Issues; Temp Files, Not Refreshing
That’s interesting, do you have IE11 installed on this PC?
Xibo 1.7.8 does change the registry (browser emulation) during installation, but IE must be installed to make it work.
Please make sure it is installed and that you have correct entry in windows registry - Enabling HTML5 in the Windows .net Player

Is your background an image(if it is please make sure it’s .jpg) or just the default black background?

Hi, Peter. Thank you for the response!

Separate Displays

Your first link is something I will try right away. The title of the post tells me it is exactly the issue I experienced - display is active and ready to start, without any license registration.

WatchDog & Screensaver

I think you are 100% right on the Watchdog front. I disabled it and disabled Xibo from the list of Startup apps. After doing so, no workstation has kicked up the desktop program, only the screensaver, which is fully responsive.

Screensaver Background Issues; Temp Files, Not Refreshing

These are Win10 machines, with both IE11 (included as legacy by MS, for however long) and MS Edge installed.

I checked the registry and the entries you noted are where they should be.

My background settings are black (#000000) AND a .jpg. The black setting is so that any padding on a screen due to scaling (a couple screens are not 16:9) is black, instead of the default white. The black setting isn’t the root cause of the observed issue, however, as when the background color setting was originally at its default, which is blank/no-setting, the bleed through was still occurring, only it was white.

And just to reiterate, I’m only experiencing the bleedthrough in the screensaver function. The desktop app has not demonstrated having this problem.