Proof of Play 1.8.0-rc2 Stats Missing


I stood up a new 1.8.0-rc2 server using Docker, and currently my client is not reporting stats. I have stats enabled, but nothing is making it to the server or database. I can see on the client side that there are a lot of stats.xml files that are sitting in the xibo library. The client is running on windows, with version 1.7.9.

Any ideas why the client would be unable to send up the stats.xml files?


If you have ‘Enable stats reporting?’ enabled in the display profile assigned to your device, then it should send proof of play statistics. Statistics reporting

Perhaps take a look at durations on your layout, it could be a good idea to also use 1.8.0-rc2 windows client with 1.8 CMS.

Yes I have Enable Stats Reported Enabled. I have had 4 different layouts running. One is a 3min video, and the other 3 are 10 second pictures. I have just upgraded the client to the new version, and still there is no stats data coming to the server.

I have completely uninstalled and removed all files on the client, and then reinstalled 1.8.0-rc2 windows client and pointed it to the server. Again, the stats files are being created on the client, but they are just sitting in the xibo library folder.

Is there any log I can check, or port I need to open to allow them to send to the server?


It seems to work fine on our dev environment, could you please double check that you’ve selected correct dates on Statistics page under proof of play?

ie for example for something that is displayed now ie 15.02, to see it on stats page you will want to select 16.02 in ‘To Date’.

As for log, yes you can enable CMS debugging, display auditing then look on CMS logs page.
If that would not be enough, you can also do this How to get a Windows Player log for advanced debugging but please read it carefully.

I am running a select query on the db table stats, just to rule out a display issue, and there are only 30 records. Whats weird is those 30 records are for a display id that doesnt exist in my system. Does this db come with data already in the table?

I dont believe the client is able to send the files to the server, is there a port I should open? I am hosting the ubuntu server from aws.

I will look at the logging, thank you.


I withdrew my previous post because I was able to get logging to work after defining the log name. That wasn’t clear to me in your guide, but logging is working now.

XiboClientAuditLog.pdf (316.3 KB)

I don’t see any error with Stats in this log. I also briefly opened all traffic on all ports from anywhere, to the xibo server. I was hoping this would resolve the issue, but it has not. Any other suggestions?

I also just stopped, the docker containers, destroyed them, and ran bootstrap again. Still not getting stats.


Two things:

  1. Open php.ini and find always_populate_raw_post_data make sure it’s set to -1 and it’s not commented out (no ; before that line in php.ini)

Please restart your web server after you make this change.

  1. You might want to configure xmr -

There are multiple copies of php.ini on the server, and they are all inside docker folders. I check one, and the line is commented out, and the value = On.

Since I installed from the Docker build, XMR should be configured already correct? I want to run this server with 1.7.9 clients if possible, so I don’t want to enable XMR, as last time I did, it caused issues on the 1.7.9 clients.

Right now there is only one client pointed to this server, and it is running 1.8.0-rc2.

I have a 1.8.0-beta server that has been working fine with stats reporting, so I am not sure what could be different here.

Please let me know which PHP.ini file I should change, and why this isn’t already handled by the docker container.

Thank you for all your help.


Right, I forgot that you have it on docker, in this case you probably don’t need to edit php.ini, as for xmr,
all you need to do is set the XMR public address in the CMS settings -> Displays tab.

XMR will be listening for players on port 9505
so in public address you will want to put something like:
or tcp://hostname:9505

replacing the ip.address / hostname with correct values for your installation of course.

I’m not sure what issues it could cause though, 1.7.9 player will not use it anyway.

XMR is setup, and the client information screen shows that it is connected to XMR. I don’t have any commands to test though, so I don’t have validation the client can execute anything sent from XMR.

Do you have a list of common XMR commands? I couldn’t find any.



I just thought to test a different client, and it worked right away. I have no idea why the other client isn’t working, as it was sending stats on 1.7.9 pointed at a different server. Either way, the issue was on the client side, and I will try to determine what that is, so I can post here for others who may have this issue.

Thank you for your assistance today.


Well, The solution to this problem, was to stop every xibo process, uninstall the program using windows, delete configuration.xml files from AppData, and delete Xibo Library folder from documents. Then reinstall and configure the client.

Not sure what was causing them to be blocked, but its working now.

Sorry for the waste of time. If anyone else see stats files accumulating on their clients, its a client issue, not server. Just reinstall everything on the client and you will be good to go.


I’ve sent you a longer pm, here I’ll just say that I’m glad it’s working now, shame we didn’t really know what exactly was wrong.

I’ll close this topic now.