Problem with Xibo Player


#1

Hi Dan/Alex,

I am getting the following errror when I Launch my player.

Is there any idea what caused it or is it a Client side or Server side error? …


#2

Although you did not ask me to answer I’ll do it anyway :slight_smile:

The main issue you need to look at is the DocumentRoot and URL rewriting (as you do have /web in the url that implies configuration error) - http://xibo.org.uk/manual/en/install_environment.html

While you making changes it might be also good to make sure zeroMQ/XMR is correctly installed, enabled and configured - http://xibo.org.uk/manual/en/install_xmr.html

Of course I assume the CMS and players are both in 1.8.2 version.


#3

Hi Peter,

Thank you very much for your reply.

Apparently , connection with XMR didn’t resolve our issue.

I have added a parameter on player side along register request parameters (for assigning display to user dynamically) and made subsequent changes in xmds and Soap5 file on the server side.I am getting the right value on the server side and the permissions are setting right.

When my player and CMS are on localhost no error is shown.But with CMS on a remote server and player on my localhost , I get this error. The code of CMS on both local and server are identical

However when I remove the changes on the server side , its working perfect.

Can this be the reason for the error?

Thanks a lot.


#4

as i understand it you should not have access to /xibo
it should just point to web
is your web server configured properly?


#5

yes…its working properly…everything…

I have installed Xibo through xampp

Also, for my above problem when i type localhost player is working as expected…but on typing 127.0.0.1 its giving me same error…

This is the exception I am getting

Exception thrown: ‘System.Web.Services.Protocols.SoapHeaderException’ in System.Web.Services.dll
Error: 2017-08-12 01:00:33RequiredFilesAgentThreadScheduleAgent - RunException in Run: __clone method called on non-object


#6

You seem to have /web in your CMS address, if even player access it like that, which implies configuration error, as I said before, please read http://xibo.org.uk/manual/en/install_environment.html


#7

Hi Peter ,

I made all the changes in the url.The problem still persists :


#8

If that’s the CMS login page, it has been heavily modified, I can only assume the CMS itself after login page was modified as well?

Looking at your page I can’t even tell if you’re using Xibo which could be ok, but I can’t even tell if you’re using software under AGPLv3 licence which is not ok, not sure what the ‘Subscribe’ button does on the ‘CMS’ login page, but that looks a bit odd to me as well.

Is Xibo source code or offer of the source code as well as AGPLv3 licence distributed to your clients by other means?
As clearly it was removed from the login page, and at least in the terms on that page I don’t see a single mention of it.

I don’t think I’ve seen this error before either, however if the CMS source code was modified, then that could explain it.
It could also be a problem with your server / php configuration (soap).

Is it 1.8.2 CMS and player?


#9

Hi Peter,

In no way we are distributing source code .We are offering digital signage services to our clients taking Xibo as base and making some customised modifications to it.Subscribe is for our clients who wish to use our service.I hope that is OK :slight_smile:

Please feel free to visit our website.

The code is original.It was modified only on the login part.

Also, the same code is working well on local

it is CMS 1.8.1 and player.

Thanks.


#10

I did not look extensively there and obviously I did not see the CMS itself, only the login page.

The only thing that must be done though is to offer your customers the Xibo source code (or offer of it) and your customers must know that they are using open source software distributed under AGPLv3 licence - basically this Open Source Xibo

If it’s working locally, then I’d say it will be something in the php settings on your ‘live’ server or some other configuration issue, are all devices connected to that CMS experience similar problems?

Perhaps @dan would have a better idea of the error you’re seeing and what may have caused it.


#11

Sure we will take care of that.Thanks :slight_smile: