Preview only displaying background color?

I just installed Xibo on my mac using XAMPP with the instructions provided. I just put together a test layout, and for some reason the only thing that displays is the background color. I’ve tried multiple browsers, all with the same results. I also tried to verify all of the modules. Any help on this would be greatly appreciated.

When you say you tried a test layout, was that in the preview or on a client? Since you mention browsers I am going to assume it is on the preview. Does the layout have any overlapping regions? What content is on the regions and layout that you made?

Thank you for your quick reply. I am previewing in browser, not on the client display. The layout has no overlapping displays. I added a simple text box with the words “TEST” I’ve also tried multiple background colors and text colors. (The background color changes, however the text and every other element doesn’t seem to display.)

I would suggest deleting any regions, create a new region and see what happens. Sometimes when two regions get created and they are of the same size and coordinates you will not be able to see that there is actually two regions. If this is the case and one of the regions is blank, this will lead to the layout not working. This could be the problem.

Thank you. I just tried this with the same results. When I inspect the page via chrome, I can visibly see the div area for where the text would be, but nothing is displayed.


Please try to create a new layout, do not set a background, set the region to full screen and then insert an image from the Xibo library on the layout.

Hey, still nothing displayed.

Any chance you could screen shot that and post what it is doing?

You may need to read a few topics before the system will let you upload the screen shot. Either that or post it to dropbox, google drive or what not and post the link.

You got it. I’ll do that right now. One thing I should mention that I just noticed that the status column shows an “x” by each layout. Could this be the issue?

More than likely. The question is why? This in my experience is because of empty regions, or the layout has something on it that is not local to the Xibo CMS so it can’t determine if everything will work correctly unless the layout is actually loaded.

Here’s the dropbox link to the screenshots. You’ll notice that the last screenshot shows the empty page. If I go in and add a background color, the background on the preview page changes.

The link is not showing, Try and read through post and the system should let you post the link.

I’m sorry, I forgot to paste the link. It’s been a long day lol.

I am thinking this must be a permissions issue on the Xibo Library folder. I think that you should check the apache server has permissions on the library folder.

Which version of the CMS did you install?

The Xibo library has full read/write access for all. I’ve installed xibo-cms-1.7.4. Is there a different version I should install?

No you have the correct version.

Can you try and access the CMS from a non Mac machine if you have access to one?

Other than that, I would say turn on full logging in the maintenance section. Clear your log file, try to make changes to the layout and then try previewing again. Afterwards check the log for any errors such as SQL errors. Have you also configured your php.ini file as described here and settings in the CMS for region and language?

Tested on a PC with the same results. No errors showing in log. I followed the instructions in that link exactly. Thank you.

Well I am at a lost here. I think you will need to wait for Dan, Peter, or Alex to respond.

My best guess is that there is either an SQL error, or permissions error.

Sorry I could not be of more help.

Thank you so much for your help. I’ll keep trying different things and wait for others to chime in.

So I just tested this on a live server… same results… However I noticed, when I make a copy of the default layout and edit on that one, It previews fine… So weird…