Players not downloading media from playlists

My players are not downloading media added to playlists scheduled as the ‘always’ event as a display group. The layout is just black giving the following error: Layout Change to “…” failed. Exception raised was: Unable to set and region media nodes.

Getting this same thing happening on multiple clients after upgrading to 2.0


Yes I am having the same issue - seemed to work when I had only one region using dynamic playlists - but moving forward and updating some other content to dynamic playlists the whole screen no longer works!

Has there been any movement with this issue at all? We are finding this on all our displays which is unacceptable. I have rebuilt blank layouts using a playlist and as soon as the layout changes (via schedule) our displays are blank (but the background).

I would appreciate a fix to this.

We’d need to see this first hand I think. It’s not something we’ve come across on a hosted install yet, and so without being able to troubleshoot it there’s not alot we can do I’m afraid.

The error suggests there’s no regions in the layout. If that’s the case, then the layout is invalid and I wouldn’t expect it to display. For a layout to be valid, there must be at least one region, and all regions must have at least one media item in them that is scheduled to be shown at the current time.

The layout has only 1 region, and the region has a sub-playlist scheduled.

And is something in that sub playlist valid? ie it’s not the case that all the widgets are outside their scheduled time to be shown?

Can you also check the Task status in the CMS. Is the Regular Maintenance task running every few minutes, and what is its status?

I THINK I just fixed it - at least in that as soon as I made the change the one display / layout started showing. I shortened the name of the playlists to under 50 characters (as par the message below the text box). The textbox does not seem to limit maximum length. So that part works.

Now I’m getting some new errors (which I’m working through) – "XmrSubscriber - processMessage – Unopenable Message: unknown block type and Unopenable Message: input too large for RSA cipher. Looks like these relate to a BouncyCastle process - not sure what length RSA key it’s using, but from what I’m finding online, increasing it to allow for larger payloads fixes that.

I have seen that error too -Unopenable Message: input too large for RSA cipher. Shortening the length of the playlist names for me did nothing.

Everything in the subplaylists are valid. They just have images and videos. No scheduled times are set.

Same here – no timeline items or media items have start / finish dates. I did manually add duration amounts on all our media items in the dynamic playlist, and work to shorten all the names just in case.

I’m wondering if the cypher length item is due to the length of the layout as a whole. After the input too large for RSA cipher I get the message “Unopenable message: unknown block type”. Then nothing seems to sync.

I did speak too soon. While the one layout seemed to start working on that display, the others did not (and we have about 80 layouts – one for each of our schools).

All tasks seem to be running fine except for Daily Maintenance.

None of the tasks are running.

Please make sure you have XTR set up and running correctly. Without that sub playlists won’t be built and your layout will effectively be empty.

My tasks are running (we had purchased time from you Alex and you fixed us all up).

That being said our layouts using dynamic playlists are not working as expected (with trying those fixes above). I really think there is something going on with how they are compiled and sent to the viewers.

As soon as I switch a layout to utilize media items added directly to the layout and/or remove any dynamic playlists, the layout works as expected.

JWhite’s tasks aren’t running and this is their thread.

None of the names go down to the Player as far as I’m aware.

The XMR message is unrelated. It means your jet isn’t synced with the CMS. You need to edit that display and tick the reset XMR box for that display.

It’s tough to try and troubleshoot two people’s issues in one thread I’m afraid.

Interesting. I’m using a docker install. Any idea why they wouldn’t be running?

It should be running automatically, but you can see the last run times are blank. Indeed they’re last year. You’re sure you’re running 2.0.1 as that’s only been available a few weeks!

Perhaps check the date and time are correct on your server, and restart the containers.

Yes, running 2.0.1. Just verified date and time are correct, stopped and started the containers, and still nothing.

I used to run on Windows IIS (back in 1.7) and moved to Linux Docker via export/import, so that last run in 2018 was probably on the Windows server.


Please can you check the CMS log for any issues related to the task runner? I’ve checked the operation of XTR on the 2.0.1 containers and it works as expected, so I can only think it’s something related to your database.

Ok so Alex - how are we going to fix this problem? Yes, this is JWhite’s thread - however we are both experiencing the same issue on a 2.0.1 docker CMS install, and have both tried the same troubleshooting items. The log files arn’t telling anything past what we’ve provided (i.e. Layout Change to xxxx failed. Exception raised was: Unable to set any region media nodes.).

I know this is a community support forum, so I really do appreciate your time. I have included a sample copy of one of the layouts. I looked through it and was unable to find any blank sections as the error indicates. The layout can be downloaded from here.

I was able to manually run php bin/xtr.php inside the container to run the tasks. Looking at other support threads it may be because my statistics are so large? Anyway, now that the tasks are running, the issue remains.