Player fall back to desktop


using Version 1.7.5 Server and clients

the School in our village uses three Client-PCs W7 64 Pro with identical Konfiguration. The Server is inside the LAN. Everything worked fine. Our layout Displays three URLs and one jpg, witch is also called by URL and is hosted on the local XIBO-Server (reason is,that this Picture changes every 4 weeks and gets always the same Name, so we are not used to use the library).

Now the Problem, that appears a few weeks ago:
When we start the Clients (are off over night), the three URLs are Displays the designed time, the jpg-URL Displays a few seconds and then the Client Displays the Desktop.

When we then watch the Client by VNC or Teamviewer, ALL URLs are displayed correctly and over the full time and there seems to be no more fallback to the Desktop. I suppose, this happens also when I would use a mouse to klick on the running Player in the Task bar.

We changed the PCs among and the Problem is still around, we think, this is not a configuration issue of the Clients.


It might be a good idea to update to 1.7.7 CMS and clients.

Do you have any 3rd party software installed on your PCs that could potentially cause problems?

So, does it happens randomly or did it stop?

As always with Windows clients it might be also a good idea to:
Install IE 11 and make following registry change (browser emulation) - Enabling HTML5 in the Windows .net Player

Also, especially when you upgrade to 1.7.7, it would be highly recommended to have fully qualified path to your CMS library in CMS settings.

More information on it under ‘Library location’ section of this post

Thank you for Response.

It seems to be this issue:

URL to be called: : With this URL the Player falls back to the Desktop

Then I made a simple html-File to Show this Picture
URL to be called: Works !

I will make the registry Change as you wrote and I will test again. An Update to 1.7.7. is not possible at the Moment.

regards from Austria

Works not !!!
Sorry guys, it seemd to work, but there is the same Problem.

I think, this Problem is to be searched within Windows 7. not in xibo. I made the upgrade to Windows 10 today on all PCs and I changed NOTHING in xibo Client or Server.

Looks like working good. I will test and Report…

Perhaps Windows 10 comes with newer IE (and/or other software/drivers) than you had, if you also installed Xibo 1.7.8 (which makes registry change to use IE 11 during installation) that could explain why it works now.

In any case, I’m glad it’s working, if you’d encounter any issues, let us know.