Media lost after reboot

Hi there,

I tried to install Xibo on Windows 10 in a Docker (Docker for Windows).

The installation was successfull but after a rebooting the server all media and layout’s are lost.

The checkbox in the shared drives settings in front of “C” is ticked.

The directory C:\users\shared\cms exist and there is some data in it. But the uploaded media isn’t there.

Please help me.

Please see the following page in the manual which describes this (in the Docker for Windows section):

Please note, that at the time of writing, there is a bug with Docker for Windows which means that when your Windows computer is restarted, the CMS will appear to lose all your Media, Layouts and Configuration. Your content is safe! Until this issue is resolved, after a reboot, you will need to manually restart the CMS containers to restore the content. To do so, you would run the following from the PowerShell command prompt:

cd \Xibo-docker
docker-compose stop
docker-compose start
where \Xibo-docker is the directory you’ve installed the CMS in.

cd \Xibo-docker
docker-compose stop
docker-compose start
where \Xibo-docker is the directory you’ve installed the CMS in.

What should I do if this doesent work? My user and media is still lost after executing this powershell commands.

I have the same problem i tried to execute the powershell commands and still is not working, lost data yet

You need to make sure that the drive you have the CMS on is still shared in the Docker settings.

Open the Docker settings, ensure that the drive Xibo is on is shared. If it isn’t tick the box to share it.

If it is, click the Reset Credentials button, and then apply.

Then repeat the PowerShell commands.

Thanks im new in xibo, where is the docker settings?
is a installation with docker toolbox on windows7 64 bit.

Hello Alex I have a problem, I’m here again, I just changed the port in Docker-Compose and to apply changes I did a docker-compose down and then docker-compose up-and again I lost data after restarting, the last time You helped me to add the ** command: --innodb_use_native_aio = 0 ** because the database did not start, the shared folders were not created, any suggestions on what to do?

FYI - docker-compose up would have been sufficient.

Your shared folders should still be in place on the host machine? So I suspect it is just a case of re-sharing your C drive

Restarting the containers manually should fix your issue (after making sure your C drive is shared still in the Docker configuration utility).


is on docker toolbox

with docker-compose up does not advance from starting web server

AdvanexMX@AdvanexMX-PC MINGW64 /c/users/xibo
$ docker-compose up
Starting xibo_cms-db_1 ...
Starting xibo_cms-db_1 ... done
Starting xibo_cms-web_1 ... done
Attaching to xibo_cms-xmr_1, xibo_cms-db_1, xibo_cms-web_1
cms-db_1   | 2018-02-15T19:04:04.051536Z 0 [Warning] TIMESTAMP with
implicit DEF
AULT value is deprecated. Please use --explicit_defaults_for_timestamp
server op
tion (see documentation for more details).
cms-db_1   | 2018-02-15T19:04:04.052561Z 0 [Note] mysqld (mysqld 5.7.21)
g as process 1 ...
cms-db_1   | 2018-02-15T19:04:04.056505Z 0 [Note] InnoDB: PUNCH HOLE
support ava
cms-db_1   | 2018-02-15T19:04:04.057081Z 0 [Note] InnoDB: Mutexes and
rw_locks u
se GCC atomic builtins
cms-db_1   | 2018-02-15T19:04:04.057364Z 0 [Note] InnoDB: Uses event mutexes
cms-db_1   | 2018-02-15T19:04:04.057769Z 0 [Note] InnoDB: GCC builtin
hread_fence() is used for memory barrier
cms-db_1   | 2018-02-15T19:04:04.058190Z 0 [Note] InnoDB: Compressed tables
zlib 1.2.3
cms-db_1   | 2018-02-15T19:04:04.058961Z 0 [Note] InnoDB: Number of pools: 1
cms-db_1   | 2018-02-15T19:04:04.059585Z 0 [Note] InnoDB: Using CPU crc32
cms-db_1   | 2018-02-15T19:04:04.061598Z 0 [Note] InnoDB: Initializing
buffer po
ol, total size = 128M, instances = 1, chunk size = 128M
cms-db_1   | 2018-02-15T19:04:04.070998Z 0 [Note] InnoDB: Completed
on of buffer pool
cms-db_1   | 2018-02-15T19:04:04.073792Z 0 [Note] InnoDB: If the mysqld
n user is authorized, page cleaner thread priority can be changed. See the
man p
age of setpriority().
cms-db_1   | 2018-02-15T19:04:04.085392Z 0 [Note] InnoDB: Highest supported
 format is Barracuda.
cms-db_1   | 2018-02-15T19:04:04.087372Z 0 [Note] InnoDB: Log scan
progressed pa
st the checkpoint lsn 13545704
cms-db_1   | 2018-02-15T19:04:04.087754Z 0 [Note] InnoDB: Doing recovery:
d up to log sequence number 13545713
cms-db_1   | 2018-02-15T19:04:04.088331Z 0 [Note] InnoDB: Database was not
own normally!
cms-db_1   | 2018-02-15T19:04:04.088737Z 0 [Note] InnoDB: Starting crash
cms-db_1   | 2018-02-15T19:04:04.104083Z 0 [Note] InnoDB: Removed temporary
espace data file: "ibtmp1"
cms-db_1   | 2018-02-15T19:04:04.104504Z 0 [Note] InnoDB: Creating shared
pace for temporary tables
cms-db_1   | 2018-02-15T19:04:04.105009Z 0 [Note] InnoDB: Setting file
' size to 12 MB. Physically writing the file full; Please wait ...
cms-db_1   | 2018-02-15T19:04:04.108696Z 0 [Note] InnoDB: File './ibtmp1'
size i
s now 12 MB.
cms-db_1   | 2018-02-15T19:04:04.110302Z 0 [Note] InnoDB: 96 redo rollback
nt(s) found. 96 redo rollback segment(s) are active.
cms-db_1   | 2018-02-15T19:04:04.110841Z 0 [Note] InnoDB: 32 non-redo
rollback s
egment(s) are active.
cms-db_1   | 2018-02-15T19:04:04.111833Z 0 [Note] InnoDB: Waiting for purge
to s
cms-db_1   | 2018-02-15T19:04:04.162869Z 0 [Note] InnoDB: 5.7.21 started;
log se
quence number 13545713
cms-db_1   | 2018-02-15T19:04:04.163895Z 0 [Note] Plugin 'FEDERATED' is
cms-db_1   | 2018-02-15T19:04:04.167595Z 0 [Note] Found ca.pem,
and server-key.pem in data directory. Trying to enable SSL support using
cms-db_1   | 2018-02-15T19:04:04.168333Z 0 [Warning] CA certificate ca.pem
is se
lf signed.
cms-db_1   | 2018-02-15T19:04:04.170911Z 0 [Note] Server hostname
: '*'; port: 3306
cms-db_1   | 2018-02-15T19:04:04.173167Z 0 [Note] InnoDB: Loading buffer
 from /var/lib/mysql/ib_buffer_pool
cms-db_1   | 2018-02-15T19:04:04.177221Z 0 [Note] InnoDB: Buffer pool(s)
load co
mpleted at 180215 19:04:04
cms-db_1   | 2018-02-15T19:04:04.177707Z 0 [Note] IPv6 is available.
cms-db_1   | 2018-02-15T19:04:04.178111Z 0 [Note]   - '::' resolves to '::';
cms-db_1   | 2018-02-15T19:04:04.178552Z 0 [Note] Server socket created on
IP: '
cms-db_1   | 2018-02-15T19:04:04.506816Z 0 [Warning] 'user' entry
t' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.507276Z 0 [Warning] 'user' entry
@localhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.507636Z 0 [Warning] 'user' entry
alhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.508150Z 0 [Warning] 'db' entry
ema mysql.session@localhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.508410Z 0 [Warning] 'db' entry 'sys
ocalhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.509028Z 0 [Warning] 'proxies_priv' entry
'@ roo
t@localhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.512250Z 0 [Warning] 'tables_priv' entry
'user m
ysql.session@localhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.512891Z 0 [Warning] 'tables_priv' entry
nfig mysql.sys@localhost' ignored in --skip-name-resolve mode.
cms-db_1   | 2018-02-15T19:04:04.531126Z 0 [Note] Event Scheduler: Loaded 0
cms-web_1  | Waiting for MySQL to start - max 300 seconds
cms-web_1  | MySQL started
cms-web_1  | DBVersion
cms-web_1  | 136
cms-web_1  | Existing Database, checking if we need to upgrade it
cms-web_1  | Configuring Maintenance
cms-web_1  | crontab: can't open '/etc/crontabs/apache': Permission denied
cms-web_1  | Running maintenance
cms-web_1  | Starting cron
cms-web_1  | Starting webserver

It had a lot of DB repairing to do, but it looks like it came up OK?

Not yet, do not create the shared folder and do not save

Where has the shared folder gone? Did you delete it?

docker-compose down will not delete anything on the host machine so I would expect the shared folder to still be exactly where it was.

The instructions for Docker Toolbox are here: are you sure you have followed all the steps?

If your shared folder has gone, I am not sure what to suggest - perhaps Alex will have some insight as he was able to help you before.

Do not delete the folder, in fact I had already had this problem and alex
helped me to fix it, xibo was already working completely, but I had to
change the port I was in, when I did docker-compose down and then up I did
not keep saving my files, then delete the shared folder and reinstalled
xibo from scratch and it does not work, it does not save

When I connected last time, we checked that the shared folder was created and that files were being created in the media library.

Xibo cannot have deleted that shared directory itself, so perhaps you’re in the wrong location? You had multiple sets of docker-compose files from memory before. You have to be in the directory with the shared folder in it already for it to be able to connect to your existing data.

Hi alex, is in the same directory c:/users/xibo, and the shared folder is
the same, the fact is that if the folder is shared in this location, but
after making the port change xibo no longer take it, and now everything new
you do is not saved.

OK, but in your last post you said there was no shared directory and it wasn’t created, and now you say there is a shared directory. So both can’t be true?!

When I changed the port, I noticed that my data no longer appeared, so I
backed up the shared folder and reinstalled xibo from scratch, waiting for
the shared folder to be created again, and it was not created, so I
returned to its place the folder of shared previous and neither reads it,
use the same file of docker-compose that you helped me to modify where you
added the line “command: --innodb_use_native_aio = 0” and I did
docker-compose stop and start, I do not know I have tried several ways of
the forums and it does not work, I am in trouble, I really appreciate your
attention alex.

But if you deleted the shared folder, all your data will have been lost at that point!

I did not erase the data, after changing the port in the docker-compose
file, I did a docker-compose down and then up -d to update the changes and
note that Xibo no longer read my data, so I backed up the shared folder in
another location and proceeded to reinstall xibo again with the same
docker-compose file that you helped me to modify, when everything was
reinstalled it was supposed to create a new shared folder and it did not.