"localhost/xibo/install/2?" Error 404


#1

I am trying to install on IIS 10, Windows Server 2016.
The Default Web Site’s path is: C:\inetpub\wwwroot\Xibo\web
And the Xibo Application path (I converted it to an application) is also C:\inetpub\wwwroot\Xibo\web
I can navigate to localhost/Xibo and it will redirect me to localhost/xibo/install and correctly show the checklist of items. Then I hit the Next button and it tries to navigate to http://localhost/xibo/install/2? and gives a 404 Error.

It seems that when I add URL Rewrite rules (import from .htaccess file) it gives me a URL rewrite error. So for now, I have not imported those. I am willing to manually enter the URLs in order to install if that is what it takes, but I don’t know what to enter. Either that or I need to know how to fix the URL Rewrite rules for my environment.


#2

The .htaccess rules we ship assume your installation is at the root of the webserver. If you’re running in a subdirectory (as you are), then there’s a line at the top that needs to be uncommented to accomodate that.

You absolutely need to import those rules in to IIS for the system to function. The manual covers the error you’re getting too. I’d suggest looking again at that.

https://xibo.org.uk/manual-tempel/en/install_environment.html


#3

Ok I’ve imported the rules into the Xibo ‘application’ and this seems to have worked. Now I am able to login but when navigating the dashboard, like clicking the Users link on the left pane gives me an error:

DataTables warning: table id=users - Ajax error. For more information about this error, please see 
http://datatables.net/tn/7

Default Web Site’s physical path is: C:\inetpub\wwwroot
Xibo’s physical path is C:\inetpub\wwwroot\Xibo\web
I have the rewrite rules imported into Xibo.
When I change these paths I get URL rewrite errors, 500 errors, or 404 errors. So I believe my paths are correct.
PHP 5.6.31, MySQL 5.6

Using the browser dev tools and looking into Network shows XMLHttpRequest error (404).

Another thing to note is I have imported a database from our old installation back in 1.7.x. If this could be the issue, how can I run the /xibo/web/install again? It is just redirecting me to /login.


#4

If you still have web in your URL, then you’re rewrite rules are not correct - the root of the installation shouldn’t be web serviceable.

Have you read the excellent guide written by someone in the community: XIBO step by step Installation IIS 8.5 on WINDOWS SERVER 2012?

It is also possible you’re getting this: https://www.saotn.org/the-length-url-request-exceeds-configured-maxurllength-value/


#5

When I visit the url localhost/xibo it hides the /web part in the url bar. So an example url is:
localhost/xibo/install

My physical path/root is set to inetpub/wwwroot/xibo/web. I believe that is correct?


#6

Yes, in that case it sounds correct - I only queried it because that is not what you said in your last message.

I suspect your install is actually OK then, and you have issues with the URL length. If you can’t work it out, then submitting a log from Xibo (report fault) and IIS would be useful.


#7

Ok, this was fixed by changing maximum query string to 4096 bytes. Now my last question is clicking on sessions or report fault comes up with “Unexpected Error, please contact support.” Even clicking Transitions or Applications. But I can access Users now.

The browser network console says it stalled on this:

EDIT: Solved. IIS had no permissions in other directories. Had to give IUSR and IIS_IUSR modify perms to all of /Xibo. Thanks for the help!


#8

Glad you have it solved.


#9

I got same problem can someone help me…?


#10

Can you create a new post please, explaining the setup you are using (Docker or Custom, Version of Xibo CMS, Operating system), the steps you have taken and the Error you are receiving.

Many Thanks.