Linux Player - Technology Preview 0.3.3-alpha


#1

We're very excited to be releasing today the second public "Technology Preview" of our forthcoming Player for Linux.


This is a companion discussion topic for the original entry at https://blog.xibo.org.uk/linux-player-technology-preview-0-3-2-a/

Linux Player - Technology Preview 0.2.1-a
#2

Hi,
Are there any plans to add the package for the armhf architecture so it can be run on a RPi?
Thanks


#3

No there aren’t at this stage. We’re focusing on getting the Player working well on the amd64 architecture. We’ve been really clear that we don’t think the RPi is a particularly suitable platform, as it’s very underpowered for our needs.


#4

Good day! Nice to see Linux client taking shape.
However, trying to run xibo-player-test produces me:
xibo-player-test --host xibo.emu.ee --server-key SeRvErKeY --hardware-key xibolinux

** (player:2741): WARNING **: 14:30:57.453: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
[14:30:57] [debug]: Display is ready. Getting required files…
terminate called after throwing an instance of ‘boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::property_tree::ptree_bad_path >’
what(): No such node (saveAs)
Aborted (core dumped)

My system is Ubuntu 16.04 and server is Version 1.8.5


#5

What do you have for SENDFILE_MODE in the CMS settings? I’m guessing Off?


#6

Good day! Unfortunately I have no way to change that setting, because it isn’t there.


#7

How have you done the install then? On a custom install, that setting should be visible.


#8

Hi,
Trying to run the Linux client I get the following error:
mkdir: cannot create directory ‘/run/user/0’: Permission denied
terminate called after throwing an instance of ‘std::filesystem::__cxx11::filesystem_error’
what(): filesystem error: cannot remove all: Permission denied [/home/XXX/Downloads/resources]
Aborted (core dumped)

I have full permissions to the directories and its run under sudo. I can create folders manually with no issues.

I’ve also tried the updated installation via docker (https://github.com/Stivius/XiboLinuxStack), I believe this is the same client? Here I get a SOAP error: [08:10:06] [error]: Receive SOAP request with HTTP error: 301

This is tested with linux 16.04 and CMS version 1.8.7.


#9

You shouldn’t be running the snap as root. It just runs as your local user account.

The Player you build with Docker should be the same. If you’re getting a 301 that suggests to me that the CMS you’re connecting to is causing a redirect (perhaps from HTTP to HTTPS). Post requests can’t follow redirects, and the player supports only HTTP connections at the moment.


#10

Hi Alex,
Thanks for the info. HTTP->HTTPS will mean the current version won’t work for our CMS :frowning:
Thanks


#11

Good day!
Unfortunately here is no such setting as SENDFILE_MODE visible. Can I enable it somehow?
Just to be sure, I upgraded xibo server to the latest, 1.8.11, still no cookie. Can https cause this?


#12

Does SENDFILE_MODE = File download mode under Settings > General? If so, it’s turned off.


#13

Yes that’s right.

If its Off then that’s the old legacy download mode. The Player won’t work with that. You’d need it set to Apache or NGINX, and your webserver would need the right modules loaded and configured in order to support that.

A Docker-based CMS comes with that setup by default.


#14

Nice!, now i’m getting further, files download, but
(player:3956): glibmm-ERROR **: 12:37:44.985:
unhandled exception (type std::exception) in signal handler:
what: No such node (layout)


#15

What did you change? You can’t just change the download mode to Apache or NGINX without supporting changes to the webserver configuration.


#16

Hello! Thanks for swift responses!
I also added module for Apache, activated and obvoiusly it works, as Windows clients still download nicely and Linux client downloads all files, but spits out this error afterwards.


#17

Can you just let me know what you added to the Apache config so we can rule that out, as it downloads nicely from the CMS instances I have access to.


#18
XSendFile on
    XSendFilePath /data/xibodata/
    xSendFilePath /var/www/xibo/library/

Hello! I added those lines to enable XSendFile, and Linux client downloads files nicely, it shows progress on terminal, as you can see. This is the end of terminal output, showing last file downloading and starting player, and error afterwards:

[14:31:09] [debug]: [68.png] Downloaded 182 bytes
[14:31:09] [debug]: All files downloaded
[14:31:09] [info]: Player started

(player:4741): glibmm-ERROR **: 14:31:09.693:
unhandled exception (type std::exception) in signal handler:
what: No such node (layout)

Trace/breakpoint trap (core dumped)


#19

You only need XSendFilePath to point to your configured Xibo library directory. One of those lines isn’t necessary.

You definitely have a default layout set, and that layout is valid? That’s what the Player will try and show? If you do, empty the resources folder and run the Player again.

Now in the resources folder should be only one xlf file. What is in that?

Can you also check you have XTR properly configured and running, and that the regular maintenance task has been run recently?


#20

Hi !
I have tried this new client for ubuntu.
I am on ubuntu 16.04 with mate, the client work but i have some problem.

When i start it i got this message : Gtk-Message: 14:44:24.672: Failed to load module "topmenu-gtk-module" it’s not a problem for xibo i guess.

After that the files are loaded and xibo is started.
The layout is a webpage with some timetable but i have some bug, the module are not refresh when i click on. I have some message like this
** Message: 14:44:27.349: console message: file:///home/tony/xibo/4.html @6: Viewport argument value "[[viewportwidth]]" for key "width" is invalid, and has been ignored.

** Message: 14:44:28.678: console message:  @0: Blocked a frame with origin "https://pxxxg.uxxxm.fr" from accessing a frame with origin "null".  The frame requesting access has a protocol of
 "https", the frame being accessed has a protocol of "file". Protocols must match.   

With firefox i haven’t problem.