Linux Player - Technology Preview 0.3.3-alpha


#21

Can you export your layout for me and send it over so we can see it here please?

To do so export the layout from your CMS, and then upload it somewhere (Google Drive, Dropbox etc) and then send me the link via PM.


#22

Hi everyone, I install linux player on ubuntu 18.04 and 18.10. Work fine, but content in player dont synchronized when a make change cms layout, only if restart player and if I change standart port of my xibo-server to 8080 for exemple, player client dont found server if I write --host as xxx.xxx.x.xxx:8080. Thanks for contributing!


#23

At the moment the Player does a one-time download of the layout. As you say it won’t download any change until you restart it. That’s the expected behaviour at the moment, but clearly not in the future.

Is it the custom port, or the IP address that it doesn’t like?


#24

Hello!
Will we have Counter module back in this Linux version?
Thanks!


#25

That’s not in the plans currently. It will have roughly the same feature set as Android.


#26

Hello !

Here is my error on a 18.04 64LTS player (with distant cms 1.8.0, same with 1.8.3) :

terminate called after throwing an instance of ‘boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::property_tree::ptree_bad_path >’
what(): No such node (collectInterval)

EDIT : seems OK with 1.8.11


#27

Its unlikely the middleware will work properly on a 1.8.0/1.8.3 CMS. We’ve only tested it with 1.8.11 - which as you say works correctly.


#28

Yes it connects to the CMS. Everything seems to work except the video files rendering really slow.
I run tests with different materials and will be back soon with feedbacks if it is useful.


#29

Hi Alex, Peter,

How are you doing.
This is great news! we all wanted a linux based player for more efficient working.

I have installed snap, then followed the instructions here. but after sending this command :
xibo-player-test --host --server-key --hardware-key
Gives an error like : Soap Resolved host with error: Host not found

Is this a firewall issue? I am connected to the internet.
Also, I have tried with other internet sources, and still found this issue.
Could this be a proxy issue?

Much regards,
Reema


#30

I very much doubt the Player will work with a proxy.

Your command is missing parameters too - you’re specifying a flag for each option but no value.

You should be using something like the command in the article:

xibo-player-test --host yourcms.example.org --server-key yourkey --hardware-key yourhardwarekey

Note there’s no http:// or https:// in the --host parameter. That’s intentional.


#31

I tried without the http, but this time it gives error (with root) :
mkdir: cannot create directory ‘/run/user/0’: Permission denied
I’m running it as root.

without root : gives , response from server with HTTP 500

Also, separately, I’m following the docker tutorial :

in this :

  • Install Docker
  • Clone this repository
  • Run docket build -t xibo-linux . in the root of the repository
  • docker run -v /path/to/local/clone/build:/build xibo-linux
  • The Player binaries will be build and output in to your build directory

In this step, after installing docker and cloning the repo, when running the last 3 steps, it starts the container, the player binaries are not placed in the build directory, its empty.
After installing docker, do we give it a particular container id? Maybe its not getting the correct container in which it should install?

Thanks,
Reema


#32

You shouldn’t be running it at root. You need to run it as a normal user.

If you’re getting an error 500 you’ll need to look in your server logs and find our why. I presume you’ve installed the Middleware correctly?

You shouldn’t be following the Docker notes from the repo. All you need to do is shown in the blog post at the top of this guide. Docker is there only to build the dependency chain which you don’t need any longer with the snap packages. Please just follow the guide exactly!


#33

Seems like it expects the background image to match the layout size, which mine don’t and other platforms seem to handle ok. I was able to display a simple layout without a background and a couple of regions, including a webpage.

(player:31937): glibmm-ERROR **: 14:35:24.904:
unhandled exception (type std::exception) in signal handler:
what: Background’s and layout’s size should be the same

./run_xibo.sh: line 1: 31937 Trace/breakpoint trap (core dumped) snap run xibo-player-test


#34

If I remove the background image it displays the complex layout I have with tickers, webpages, and other images.


#35

Hi Alex,

Thanks for the help. We have tried with the snap method as well as by the docker method (by building from source).
Right now, we face the same issue as below -

terminate called after throwing an instance of ‘boost::exception_detail::clone_impl<boost::exception_detail::error_info_injectorboost::property_tree::ptree_bad_path >’
what(): No such node (saveAs)

After the display is added, and authorized, we see this issue and process gets aborted.
We saw the same behavior with CMS’s default layout as well as with custom layout.
We don’t see anything in the advanced > logs section. Can you please help here?

Thanks,
Reema


#36

I’ve already answered that question above (Linux Player - Technology Preview 0.3.3-alpha). It’s because your CMS isn’t setup for HTTP file downloads.

If you connect it to a Docker CMS it will work, or alternatively you can configure your existing CMS for http downloads.


#37

Yup, got it. Set it as “Apache” (settings > general > file download mode). It has two more options “off” as well as “nginx”. Do we need to change at Apache config level setting also?
But still same error :expressionless:
Do I need to update CMS to 1.8.11, then only it will work?


#38

It needs to be set as Apache, but your webserver also needs to be configured to support that.

You need the mod_sendfile module installed and configured to allow direct download from your CMS library.


#39

Hi Alex,

On setting the configuration on apache, the files are getting downloaded as below :blush: , I didn’t need to upgrade CMS to 1.8.11


What is the next step? I don’t see the player anywhere showing this content.
There are no errors also. It keeps collecting the data that’s all.
Do I need to enable any GUI component to see the player working?

Thanks,
Reema


#40

Just changing that setting to Apache won’t fix the downloads. You also need to install the mod_xsendfile module for Apache and configure it.

I also don’t think you’re running the right Player version. That looks like something newer than the version we put out. Are you sure you’re on the beta channel?

What does snap list show?