Layouts won't get displayed in V2.0.0


#1

Hi,

we have the problem since the update to 2.0.0, that our layouts won’t get displayed in the editor:

Cache cleard as well.
Any suggestions?

Regards


#2

We tried serveral things - without success :frowning:

  • more RAM to the virtual machine
  • different browesers (Firefox, IE)
  • cleard cache each time
  • first “Checkout” then “Design”
  • copy the layout and design the copy

But not all our Layouts are affected, roughly 50%.
The other layouts show up right in the new Layout-Editor.


#3

We found the problem for this issue!

We had layouts with no background color specified:

<layout width=“1920” height=“1080” bgcolor="" schemaVersion=“3”

Even if a picture is/was set, if the field “bgcolor” has no numer (like bgcolor="#000000"), you won’t be able to open such a layout in V2.0.0!!! And you have no chance to change the background color, because this was removed from the “Edit” menu.

So please make sure you have specified in all layouts a background color prior upgrade to V2.0.0!!

We had to replace the VMs HDD (with V1.8.12), specify a bgcolor on all layouts and re-upgrade.
Now everything works as expected.

Regards


2.0.0 Released
#4

Thank you for your report and for writing up your findings.

I’ve logged a bug here so we can get that addressed:


#5

Good find Gustel - I was wondering why I couldn’t open our layouts. It probably goes without saying, I was able to get this to work by going into the database and manually setting the backgroundColor field to something (I used #000). Depending on how many layouts you have, you can either do this row-by-row or via query.

Note that with the new check in / check out, a new version (and thus a “new” layout) is created, so do those as well if you’ve checked any layouts out first.