Intermittent Login Errors, form has expired


#1

Hello,

I am experiencing difficulties with a custom installation of Xibo CMS 1.8.11. I have installed it on a Windows Server 2012 environment, and am using PHP v5.6 on IIS 7.5. Whenever a new user is attempting to log on they will experience the following error upon a successful login: Sorry the form has expired. Please refresh.

After some period of time, it will allow the user to sign in and they will be able to work inside of the CMS as originally intended. This period of time can span between a couple hours, to a couple days. I cannot find anything in the log table, nor in the server logs that points to any specific cause for this.

EDIT: We have tried this on Firefox, Internet Explorer 11, and Edge.

Attached is a picture of the console while trying to troubleshoot this issue.

Any advice or suggestions would be welcomed.


#2

Additional Information: If you click on Dashboard and log in enough times, it will open the CSS Page in Notepad. After it has been opened in Notepad it allows you to sign in by refreshing the webpage.

This is bizarre behavior.


#3

The issues you are experiencing suggest something is clearly not configured correctly, especially if you are able to access CSS pages just from repeatedly logging in and clicking Dashboard.

There is a Guide for setting up Xibo on IIS 8.5 on Windows Server 2012, I have included a link so that you can take a look and see if this helps with your own setup:

You may also find that other users beneath the Guide may be able to help you with your issue.

Many Thanks.