Error swapping to HTTPS. E = Unable to connect to the remote server

We are using Versioo 2.2.1
The Windows Player running on Windows 10.
Uploaded 20 videos. It worked few times… now after some time the player goes completely blank
Log below
ScheduleManagerThread|16-12-2019 16:17:25|Error|Schedule - OnScheduleManagerCheckComplete|Agent threads/XMR is dead, not updating status.json
RegisterAgentThread|16-12-2019 16:17:30|Error|RegisterAgent - Run|Error swapping to HTTPS. E = Unable to connect to the remote server
RegisterAgentThread|16-12-2019 16:18:32|Error|RegisterAgent - Run|Error swapping to HTTPS. E = Unable to connect to the remote server
RegisterAgentThread|16-12-2019 16:19:40|Error|RegisterAgent - Run|Error swapping to HTTPS. E = Unable to connect to the remote server
RegisterAgentThread|16-12-2019 16:20:41|Error|RegisterAgent - Run|Error swapping to HTTPS. E = Unable to connect to the remote server

Below log is from another device

I have this exact same problem with CMS 2.2.1. My player will play for a short period if I restart the player. But then it goes to a blank screen and does nothing.

I downgraded app to version 2.0 … it worked again for 30 min or so… again same problem

Hi Vinay_Katwe and Will_Test, welcome to the Xibo Community!

I can see that you both mentioned you are using 2.2.1 CMS but I cannot see what version your Windows Players are, could you both confirm the full version number please?

Vinay_Katwe: I also cannot see the full VideoPlayer Error you are receiving, can you provide the full error message please? Could you also confirm the following:

  • Are all of the videos the same format and what format is that?
  • You mentioned you have 20 Videos, does the Layout successfully play all the way through before the issue occurs?
  • If you schedule less Videos, is the performance different?

Will_Test: You mentioned you have the exact same problem, can you confirm that you are receiving all of the same errors as Vinay_Katwe and if possible provide screenshots?

Many Thanks.

Hi Dan,
Initially, I used Latest version of Windows player (just downloaded last week… i assume its 2.2). However, when i got this issue, I configured the App to 2R200 (2.0) . result is same…
Video format : All videos are .mp4 format with resolution 1080x1920 (portrait videos) with 1mb to 4 mb majority of the videos. Couple of videos around 40 mb
i reduced number of video to 8 videos (consisting of all .mp4 videos between 1.5mb to 4 mb)… the result is same
All the videos play multiple cycles at least for 30 min… then the screen goes black
I went to library and verified that the videos play correctly
Yes. When i scheduled less videos, the issue is less frequent (instead of 10 to 15 min, now the black screen appears after 30 to 40 min… some times goes to 2 hrs)

As this is windows 10 - might be worth checking the power management tab against your network card isn’t set to turn off device to save power.

In power management, the option is set to “never” – I had checked this before…

Another point to be noted : When the device starts showing blank screen, even the info screen (on pressing " i "), doesn’t work… i have to force close the app and re open and then, " i " works.

Here is another screenshot… this time it seems to be a different error.

Thank you both for the info on this. Unfortunately I still haven’t had the full VideoPlayer - ErrorEvent message passed on, Vinay_Katwe can you confirm the full error please so i can see what the issue is that the Player is returning?

Cold you also confirm when this issue happens whether any of your System resources such as memory for example are reaching their limit, or returning any warnings or other errors in Windows Event Viewer?

Many Thanks.

I figured out my issue. I’m not sure if it will be the same issue Vinay_Katwe is having. I had to change machines running the player. I was using a HP Compaq Pro SFF 6005 I think is the exact model number. Anyways I was running a fresh Wondows 7 64 bit install with 4gb ram. However for some reason after awhile it would start running extremely low on available memory. That’s when I would get this message. I switched to another machine with 8gb ram and haven’t had a problem yet. Hopefully this helps everybody involved with the same issue.

Thanks for updating the post Will_Test and for confirming that switching to a new machine with more Memory seems to have helped with the issue so far.

Many Thanks.

Make sure you don’t have the Force HTTPS option enabled in the CMS Display Settings Profile if your CMS doesn’t support SSL connections.

Yes. I have the same observation… There seems to be a memory leak in the windows app. We ran multiple tests and figured out that, the app starts with 100Mb memory usage and gradually increases to about 800 Mb and then throws errors related to running out of memory and screen goes blank. Below is my system configuration
Processor Intel celeron N3050 1.6GHz
Windows 10 64bit

I created another setup with 1.7 version (both CMS and Windows app running 1.7)… so far it seems to be working fine from past 6 hrs or so… this is the first time I see app running more than 2 hrs on the above mentioned hardware

I also tried combination of Latest CMS (v2.2) with 1.7.9 Windows App. I disabled Force HTTPS. Result is same… after about 2 hrs, the screen goes black

At present, the system is in black state. If needed, I can share anydesk details to login and debug (please share your email id to share personally)

Why 1.7 Windows app? 1.7 isn’t supported any more and receives no more updates.

We do know that if showing some websites the Windows Player will leak memory. It’s a well known and extensively documented issue with the .net WebBrowser control and it isn’t something we’re able to fix directly.

We will be offering an updated Player based on Edge in Q1 2020 which should not have the same issue.

If you’re not showing webpages, then you should make sure you’re running the latest Windows Updates, particularly with reference to the .net framework, and that you are running the latest graphics driver available for your computer directly from the graphics chipset manufacturer (Intel, nVidia etc). The ones Microsoft provides are often outdated and have been known to cause problems in the past.

I just wanted to figure out the issue … so trying multiple combinations to somehow fix it.
Test Setup 1 : I am running Version 2.2 app with 2.2 CMS - Ended up in black screen
Test setup 2 : runnning 1.7.9 with 1.7 CMS - Working fine so far (more than 7 hrs). So looks like there is something wrong with new version (not sure if this is CMS or App issue)
In test setup 1 : I tried a) Disabling Force HTTPS 2) Windows Update 3) Codec update 4) Cleared Memory by removing unwanted windows applications including cortona, anti virus etc - NO LUCK 5) Reduced files from 20 videos to 8 videos 6) Converted .mp4 to avi

mp4 videos are ideal. I’d be very suprised if it is videos causing this. It is normally where you have embedded webpages in your rotation. Do you have that?

No we don’t have any webpages or anything else apart from .mp4 videos.