Docker Ubuntu not reachable after reboot


I am running Xibo on Docker on a Ubuntu 16.04 virtual machine.

After running a “apt-get upgrade” and a reboot, my docker containers seem to be up and running, however I’m not able to connect to my webinterface.

All 3 containers seem to be running fine, but I’m to new to docker to verify if everything is ok.

When I run “docker ps”, I can see all 3 containers are running.

Does someone have any ideas on where to start looking for the problem?

Thank you.

From your installation directory, run:

docker-compose logs

Does that show any errors or issues?

I tried that and I only see some warnings on cms-db_1:

[Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option

However, it also states:

MySQL started.

Everything else seems fine.

What do the logs from the CMS web container show?

docker-compose logs cms-web

The logs:

cms-web_1 | Waiting for MySQL to start - max 300 seconds
cms-web_1 | MySQL started
cms-web_1 | DBVersion
cms-web_1 | 133
cms-web_1 | Updating settings.php
cms-web_1 | Configuring Backups
cms-web_1 | Configuring Maintenance
cms-web_1 | Running maintenance

So it’s running maintenance currently. When that finishes, the CMS web interface will be available.

We’ve seen a couple of issues that can cause maintenance running to take a long time (it should take a couple of seconds normally).

Was this a database imported in to Docker from a 1.7 install or 1.8 custom install?

The database was imported from 1.7.

I allready had some problems with xmr but thought I solved it.

In that case then, it’s likely that the XMR configuration is wrong and that will need to be adjusted as follows:

To correct it, connect to the MySQL container and then run the following SQL:

UPDATE `setting` set `value`='tcp://cms-xmr:50001' where `setting`='XMR_ADDRESS';

Then exit out, delete the CMS cache directory at shared/cms/library/cache, and then restart the containers.

Instructions for connecting to MySQL to run that command here:

1 Like

Wow! I did what you told me and it worked flawlessly :slight_smile:
Thank you so much.

This settings also solved my problem with my xmr connection. I now get my screenshots back and my test player accepts commands.

1 Like