CMS error - protocol violation


#1

Hi,

I’ve recently installed Xibo CMS on a debian stretch server using the docker compose package.
Everything worked smoothly until I tried to connect with the windows client, then I got The server committed a protocol violation. Section=ResponseStatusLine with the android client I get unable to connect ot that cms address.
I also tried opening the CMS adress in Firefox where I get a bunch of gibberish, on Chrome I get ERR_INVALID_HTTP_RESPONSE, to me it looks like the cms is outputting malformed xml.

Something is fishy but the install seems fine otherwise (the self check says all good)… has anybody got an idea how to fix this?
Thanks


#2

I will need more information to better understand the issue. can you answer the following questions:

  • What other services are running from the machine?
  • Are you using custom ports?
  • Are you using a proxy?
  • Is force https enabled without setting up https?

With more information I can look into this further.

Many Thanks.


#3

Thanks for the reply.

Xibo is the only service running on the machine at the moment.
The web-gui is running on a custom port but CMS/XMR is on default 9505 and I am not using a proxy.
I did not check force https in the gui.

One thing I also noticed is that xibo does not produce any log entries, even when I set logging to debug level


#4

Thank you for the information. Can you to run the below sql statement and confirm the response you receive.

SELECT setting,value from setting where setting=“FORCE_HTTPS”;

I have included the Guide to running SQL statements on Docker for reference:

Many Thanks.


#5

Alright thanks, here is the output from the sql statement:
xibo_force_https


#6

Thank you for running the statement. Can you also run the following command and provide me with the response. Please note you will need to replace file.yml with the compose.yml file you are using:

docker-compose -f file.yml logs cms-web

Many Thanks.


#7

Sorry for the delay, here is the output:


#8

No need to apologise for the delayed reply. The output does not show an obvious issue.

If you can private message me the Login details or Team Viewer credentials, I can take a closer look for you.

Many Thanks,


#9

I have the same issue but I run Xibo on a CentOS7. I also ran the MySQL statement to make that https is not forced.

Any resolution to this?