Clock - Day of Week english and german

I am testing the clock module in 1.8. I use Firefox to run the Management consule which comes in german.

I am using DayofWeek in Format [dddd], the designer Shows “Donnerstag”, the Player Shows “Thursday”

Player is Windows 7 german, Server and Player on the same machine

regards from austria

It seems to work fine on our dev 1.8.0-rc1 CMS Instance.

CMS → Settings → Regional
The language changed to de
Donnerstag in CMS and on the player (also 1.8.0-rc1).

Could you inspect this element and see if it has var locale ="de"; ?

Hi Peter,

we stepped back to 1.7.9 for testing. In Settings / Region language is en-GB after Installation. In 1.8 we changed into “de-DE”, now we changed to “de” and it seems to work.

I dont know where to find this script, sorry

btw: I have only one Region with the clock module in it, Duration is 5 seconds, but when i Change something eg. font size, the Player does not reakt. I thought that the layout is loaded when the longest Region Ends. the Player loads the layout when ending it and restart manually and also after some time I cannot determine (15 min ??)

best regards from Austria

sorry for my bad english…

ok, I’m glad it works with 1.8 and de in language.

So, without XMR, after you make change to layout, resize regions / add content etc.
Your player will need to connect to the CMS and download updated content, player connects to the CMS, each collection interval, a settings that can be adjusted in Display profile options. (Display settings -> edit display profile assigned to your device -> collection interval).

Once player did that, next time your layout reloads it should display updated layout.

With XMR configured, all changes will be pretty much instant (+ time to download new content if something was added).

thank you…

I read about XMR and tried to understand, but I dont…
all tutorials and documentation is for Ubuntu / Linux, I do not find some for windows

I have to install this zeroMQ… ok, I can download and install this… and then?

Please help a user who is not so firm with this things…

Regards the ISO code usage. I had a similar problem with en-US vs en-GB (which is an important distinction) and noticed some JavaScript libraries would have an error because there was only the “en” version.

Check the JavaScript error console if you can and check if you put in the ‘correct’ language code, what exactly goes wrong.

These are the ISO codes:
de German
de-AT German (Austria)
de-CH German (Switzerland)
de-DE German (Germany)
de-LI German (Liechtenstein)
de-LU German (Luxembourg)

If you have zeroMQ installed and enabled, the xmr.phar is in the 1.8 distribution.

The recommended way to install 1.8.-rc1 (via docker) would come with xmr pre-configured for you.

Then all you need to do is to configre listenOn and pubOn in config.json and in CMS as described in the XMR manual page.

You can also take advantage of our Cloud hosting, that will come with XMR configured and ready to use.

here again,

running 1.8.1 on my Test-Xibo and on some customers Xibo. Test-Xibo on Windows 7, cust Xibo on Windows 10

Test-Xibo Shows Dienstag, 25. April

CustXibo Shows Tuesday, 25. April

Problem persists with Region “de”

what to do?

hey guys
i reanimate this thread :slight_smile:

i also have this problem with the language.
i set the language under settings-> region to “de”
but the players just show the time in english. (friday)

the client system is a Windows 10 1809 with german language settigs but the installation is english.

Xibo Server 1.8.11
Client Player 1.8.11 and 2R200

i hope somebody can help me with this issue.

thank you


I recommend first that you update your Xibo to 1.8.13. That would fix a lot of bugs.

Than in Seetings → region: “de” is correct Timezone: GMT +2 (Europe, Berlin) Dateformat: d.m.Y H:i

Detect Language is hooked on Calender: Gregorian

This settings work for me.

Xmr: Howtos: Custom Installation on Win10 with Xampp in German - #5 by SteitzTo

thank you for your answer.

in the meantime i upgraded xibo to 2.1.0 and all clients to r200

i do the settings to region: “de” is correct Timezone: GMT +2 (Europe, Berlin) Dateformat: d.m.Y H:i

the editors preview shows me the right time … “mittwoch … september …”
but the clients still in english :confused:

is there any little trick how i can change the displayed “time” at the clients from english to german?

the client is a windows 10 1809 enterprise with a windows in english + language change to german.

thank you :slight_smile:


a few days are gone … :wink:
here a short feedback:
i changed all reginal settings at the clients
also i updated the cms to the newest version.
i used the time code like in my last post.
and … IT WORKS CORRECTLY :slight_smile: