Can't view library

I’m trying to use an existing powerpoint doc for a region…

When I go to click on “View Library” on this dialog nothing happens -?

Again, what CMS version are you using please?

Also is that on the super admin user or your own created user user type?
In the later case, does that user has permission to the library and to that existing file in it?

We’re using 1.8.1. I’m getting the same thing with every user - both super user and group admin. The view library button doesn’t throw an error - just that nothing comes up.

Is it the same when you click on Library from the left panel and not through Image -> View Library?

What browser are you using please?

It would be best to upgrade the CMS to 1.8.2 and see if the issue persist.

Yes, if I go to Library > Media everything is there.

I’m using Chrome 61.0.3163.100

It’ll take me some time to upgrade to 1.8.2. The server isn’t online because of how our firewalls are set up… I have to pull it off the rack and modify the routing in order to get it online (not sure if there’s an easier way?)

Is it a Docker-based install? If so, you can transfer the Docker images to it out of band (ie without it having internet access).

Ok, interesting… I don’t know much about that… trying to learn as I go. Is there a tutorial you can recommend? Since this is in use I’m very concerned about screwing something up.

You’d clearly choose the 1.8.2 images rather than 1.8.1 as shown in the example.

Once you have the images loaded on your machine and available, then you’d do the upgrade as normal (ie backup, put fresh docker-compose files in place, and then bring the updated containers up).

Thanks… hoping to try the upgrade today.

I did find someout out that might be interesting… this behaivor only happens on the layout where I explicitly set permissions for other users.

For instance, in the list below everything on the TEST layout works fine - I see the items in the timeline as I add them and I can view the library. If I open up the EHS layout, no matter which user I’m logged in as, I can’t view the library and items don’t show up in the layout. I also got the error in the console below as I tried to add items.

Also, when I took out all of the permissions and just left it blank like this everything worked again… then I gave view+edit permissions to just ehs and ehs users and it worked ok.