Autoplay audio website

Hey,

I have a problem with playing sounds. In earlier stages, post, the problem was solved. But now the policies of autoplaying sounds has been getting pretty strict.

The problem is the webpage inserted in the layout (using “webpage” module) isn’t playing the sound whenever a change is made (called a new ticket). In chrome, the error is " play() failed because the user didn’t interact with the document first". Various attempts are made to no avail (using iframes, playing silence.mp3 first, muting and unmuting the audiofile using javascript).
Apparently, there is an option to start chrome with the policy the allow autoplay (chrome.exe --disable-features=AutoplayIgnoreWebAudio).

Is there something that can be done to let sounds play?
Is the webpage-module opening the site with IE/Edge or Chrome?

1 Like

Hi Vinnce,

Which Xibo for Windows Player version are you running? If you are running 2R252/3/4 then the Players are using CEF (which is Chromium based) to show webpage content and the development team has just confirmed they will be working on the enhancement you need in the next release, see https://github.com/xibosignage/xibo-dotnetclient/issues/149

Hi Nell,

Thanks for your reply.
We are using the newest version, V2 R254.1. I already suspected our players to be using Chromium-based web-browsing/displaying.
We will see if you can get the enhancement for the no-gesture requirement working.

1 Like
The Xibo Community site uses cookies. What are cookies?