Adding new client: "There has been an unknown error with XMDS"


#1

I am trying to add a new client to my pre-existing Xibo implementation and receive the following error message when clicking ‘save’ in Player Options:

"The request failed with the error message:

There has been an unknow error with XMDS, it has been logged. Please contact your administrator"

I currently have 3 displays (implemented on 1.6 and since upgraded through 1.7 to 1.8.12 whcih is there version I am running now).

I have configured the CMS address and server key exactly as it is configured with the working clients.
Nothing appears in the XiboAdmin log.
Nothing appears in any log files on the client.
I have checked the config file in the XiboLibrary directory and it appears to be correct.

Does anyone have any other possible solutions or advice?

I have searched around the Internet and on the Xibo forums but haven’t come across anything that’s pointed me in the direction of a possible solution.

Further configuration information:
Server: Windows Server 2019 / IIS 10 / PHP 7.3.1 / MySQL 8.0

Thanks in advance!


#2

Does anyone have any suggests no matter how large or small?

I’ve not been able to add any displays since upgrading to 1.8.12

Thanks in advance!


XMDS error after upgrade
#3

Does existing players connect without problems?
Do you have /web in your CMS address?

Have you necessary adjustments to the URL rewriting after 1.8 upgrade? https://xibo.org.uk/docs/setup/prepare-your-environment


#4

Hi Peter,

Yes, I have 3 players in differerent locations that are all still working as expected.

I have configured a host header binding in IIS (and assicated DNS record) to allow me to configure the CMS address as http://xibo which is working for the 3 existing clients. I have, however, tried setting the new client config using the IP/web and hostname/web and I still receive the same error message.

I had the URL rewriting set up in IIS when I previously upgraded to 1.8.0. It’s only recently that I upgraded to 1.8.12 when I moved everything to a new IIS server (running Windows Server 2019). Should I expect the other 3 displays not to work if this was not configured correctly? I have checked and it is all configured as in the documentation you have referenced.

I will go back over all of the settings and triple check… Any other thoughts?

Thanks in advance,

Richard


#5

In case anyone else lands on this topic after a Google search I have an update. I’ve just upgraded to CMS version 1.8.13 and was able to add and authorise the new display. I assume a bug has been addressed to fix this issue between version 1.8.12 and 1.8.13, although I have checked through the release notes and cannot see anything relating to this specific issue.

I hope this helps anyone in the future!