1.7.8 player won't launch

I just downloaded 1.7.8 on my Windows 10 PC. When I try and launch the player nothing happens. Xibo settings launches correctly and my older version player launches correctly. I can see the player consuming memory in my task manager but it seems to reset itself over and over, as the memory usage keeps reverting to 0%. Any advise?

It would be probably best to uninstall all Xibo players completely, including settings in /users/<username>/AppData/Roaming/XiboClient.config.xml

Then make a clean 1.7.8 install and see if it will work.

I had this same problem and the only way was to format the pc

Are you renaming the EXE or is everything standard?

1.7.8 will actively run the Xibo Watchdog to make sure everything is running correctly. You could try to disable that and see if it makes a difference.

See The Windows Player automatically restarts itself / Windows Player Watchdog

Hi guys thanks for the advice. Unfortunately I am still having the same problems. I have tried this now on 3 PCs (2 brand new PC stick nucs and my work laptop), same result on all, player not launching.
I have renamed the watchdog Exe file and still nothing.
Anything else I can do?

So we had new computer to load today and loaded 1.7.8 (Windows 10) and the XIBO Admin would start but not the client. After double checking that we had all the requirements met we removed 1.7.8 and loaded 1.7.7 and the client started with no issue. Sounds like a bug in 1.7.8 for sure.

Is 1.7.7 CMS and client still available to download somewhere? I need to get this system up and running so if 1.7.8 has issues will need to roll back

New to Xibo and had the same problem with the 1.7.8 client.
Thanks to this post, I tried the 1.7.7 client and things are working.

I took note of the URL when my mouse hover of the 1.7.8 download button and just copy it to a new browser and change the version number.

Be Blessed. :wink:

tried uninstalling 1.7.7 and manually deleting the config xml file, but the same issue. 1.7.8 doesnt load.


If someone is willing to debug this in more detail, I am very curious to know:

  • What environment you are running
  • whether there is and error message
  • whether anything is recorded in the Windows Event Log (the application log)
  • the installation folder you chose (default or otherwise)

I don’t think its a W10 problem as we’ve tested on a W10 install without problems.

I had this same problem even with windows 7
I’m sure this happened because the client installed over the old version 1.6.4 .
One of Windows needed format ( Windows 10 )
and a windows 7 'm still trying to solve


We are using Windows 10, our XIBO is at 1.7.5.
No error message we just get a busy circle every 3 seconds or so next to the mouse after launching the client. I’ve examined the application log and can’t find any XIBO related error messages. Happy to export it if you wish. In the task manager I can see the processing starting and stopping with new PIDs every 3-4 seconds. It is so fast that you can’t click and get additional details.
Used the default installation folder.

I disabled watchdog and got the same issue.


When you disabled the watchdog are you 100% sure you’ve killed any running watchdog from the system tray? You may be better looking in task manager for XiboWatchdog.exe and making sure its not there.

The only reason I keep mentioning the watchdog is that it might be the cause of the restarting - it could also be something else completely, so if you are sure you’ve disabled it then we need to look deeper.

Can you look at adding a “trace listener” so that we can get a log file?

Open the XiboClient.exe.config file in the installation folder and add the following code between the <configuration></configuration> elements.

    <trace autoflush="true" indentsize="4">
        <add name="myListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="XiboDebug.log" />
        <remove name="Default" />

The log file will be called XiboDebug.log and will be saved in the installation folder.


Double and triple checked. XiboWatchdog.exe was not running. That was my first thought.

1 Like

see my edit above - you were too quick for me :smile:

My windows 10 clients did not work either. I simply changed the Xibo folder on the windows clients to c:\xibo

Ha! On the machine that was having the issue I’ve gone back down to 1.7.7. Give me a few hours and I’ll remove that and re-install 1.7.8 again and setup the trace.


I would like to debug, as is happening in one of the windows 10 I have installed.

In my happened that I had the CMS 1.6.4 and upgraded to 1.7.8
When I was changing the players have some problems as follows
1 The machines with windows 10
2 I installed the 1.7.8 version without uninstalling the older version.
after that, no more fuincionou only in Windows 10 .
With Windows 7 , I had this problem , but it was only desisntalar to 1.7.8 and install 1.7.7 it worked.

If you can collect a log using the instructions in my previous message - then that would be appreciated.

I am thinking that it might be a .NET framework issue - can one of the people having trouble let me know what framework they are using?

Happening to me on .NET Framework 4.5.50709.

It was fine installing last week using 1.7.7, now I’m installing 1.7.8 on a fresh install of windows and Xibo will not launch, just resets itself over and over.

EDIT: Upgraded to 4.6.00081 and the issue remains.

EDIT 2: Uninstalled 1.7.8 and installed 1.7.7 and Xibo runs fine.