ZeroMQ on Windows Server 2016 not working


#1

I have tried everything. I did everything detailed in this guide.

I have downloaded and installed every single version of VC++ from 2008 on.
All the files are unblocked. I put the libzmq.dll in both locations within the apache folder.

I keep getting the exclamation point and not the check.

Any other ideas? I would rather not result to IIS since that will be backtracking for me and docker is out of the question. The environment is too restrictive for that.


#2

You’re definitely running Apache as a service, as those instructions make that assumption. And you’re restarting Apache as it won’t pickup that change otherwise?


#3

Yes.

After looking in the apache error log I am getting this…

PHP Warning: PHP Startup: Unable to load dynamic library ‘C:\xampp\php\ext\php_zmq.dll’ - The specified module could not be found.\r\n in Unknown on line 0

But the dll is in that folder and its not blocked.


#4

Forgive the stupid question - I assume that the DLL is indeed in that location?


#5

Ok, well this part about the .ini: ‘\XAMPP\php\php.ini with extension=php_zmq.dll’ means the php_zmq.dll needs to be located at ‘C:\xampp\php\ext\’ like your error states - make sure you have it there. Otherwise, I received the same error even though I had the file in the right place however in reality it was the libzmq.dll location that was of issue. Try running ProcMon to capture what is happening during the initialization then review it for any instance of libzmq.dll and add libzmq.dll to any spot it looks for it (that makes sense for you)