You have exceeded your library quota - Xibo 1.8.1


#1

Vanilla install of Xibo here - just installed last night using Docker on a Windows 10 box. CMS installed without error and everything appeared to start up correctly, however I’m having permission issues when attempting to upload files to the Media Library as any user except the Xibo_Admin.

I have created several users with permission levels ranging from User to SuperAdmin and explicitly defined their quotas as 100Mb, as well as giving them full access to the CMS.

When attempting to upload an image (less than 2Mb), irrespective of user, I always receive the error “You have exceeded your library quota” and the image I’m attempting to upload is dumped to \xibo-docker\shared\cms\library\temp instead of numbering the file and putting it in the library as per usual.

If permissions are explicitly defined on an image the Xibo_Admin user has uploaded it can be deleted by any user.

All users can create layouts and share them between themselves and use images that the Xibo_Admin has uploaded.

I’m stuck - any help would be appreciated.


#2

You definitely set a 100MB quota and not a 100KB quota?

Does it change if you set it as a quota in KB rather than MB or GB?

The reason the file goes in “temp” is because we can’t know for sure how big it is until it’s uploaded. The browser sends an indication, but it’s not reliable.

In that case, the maintenance task will clearup that temp file in due course.


#3

Have removed the Docker install from the box as it was impacting NIC performance. Will change platform to Ubuntu / Linux and start again.


#4

I have the same error. Only when set quota on user to 0 - works fine.

My config - Xibo 1.8.1 in Docker - migrated from 1.7.9.


#5

It will be fixed in 1.8.2 - https://github.com/xibosignage/xibo/issues/1180


#6

Is it possible to edit manualy lib/Entity/User.php and correct this error ? But i cant find this file


#7

Hi

I am using Version 1.8.1 and its giving me same problem. My user account cannot add a new media.

I have enabled permissions for library and added quota 500 MiB both for user and user group. But still when i login with my user account i can go to the add media then i can select a image file regardless its size i am getting the error “You have exceeded your library quota”.

What should i do. Any solutions?