XMR Setup HELP - Errors in xibo logs

Hi all,

I believe I have ZeroMQ setup properly, I have a big tick!

My state of affairs is:

Server 2008r2 running xampp

Here is my config.json

“listenOn”: “tcp://localhost:50001”,
“pubOn”: [“tcp://”],
“debug”: false

And here is by Settings in Xibo:

XMR Private Address: tcp://localhost:50001
XMR Public Address: tcp://

I do get this on the player when pressing ‘i’:

XMR Status: Connected to tcp:// Waiting for messages."

The listbox underneith this contains nothing.

So it appears to be connected, however I keep getting the error logs in xibo:

Can anyone help? I feel like ive been going roun in circles for 2 hours now :frowning:

Many thanks in advance!


Could you confirm the CMS version please?

The config.json looks fine, assuming that your player can reach that address, I wonder if your xmr is running at all, have you started it from the terminal or created a service to start it automatically? It is described here https://xibo.org.uk/manual/en/install_xmr.html

Hi Peter,

Thanks for getting back.

Please ignore my ignorance… from reading it is just as simple as cmd “php xmr.phar” yes? As below:


When I run this I do see ports appear in apache.


Sorry peter, also CMS Version 1.8.2

Hi Peter,

As an update ZeroMQ is definitely setup as I have no PHP errors in apache logs.

I am however struggling with the Xmr.phar in cmd. As you correctly stated it doesnt seem to want to start properly. Please see the screenshot below:

What would cause this?


It should stay running - not immediately quit like that.

You might try enabling debug in the settings.

Hi Alex,

Where am I enabling debug sorry? I have debug set to true in config.json but that’s all I get in log too.

Is there a debug somewhere else?

P.s. apologies for the second post in dev. I’ll reply here.


If you look at the XMR installation article Peter linked you to, the example config.json has a debug switch set to false. You’ll want to set it to true.

If that’s how you have it already, then it sounds like something more serious. Perhaps the ports you’ve specified in the config.json file are in use already? Or the user you’re running as is limited in some way?

Hi Alex,

Yeh, just what appears in the CMD window is what gets posted to the log file. No other info unfortunately.

User is the domain admin account which is what xampp is running.

Ports are as follows which are in use, however something really doesn’t look correct at all, any clue?:

Thanks again!

I’ve never seen that I’m afraid.

Your config is wrong though. You need to specify either an IP address or interface name in config.env.

You want something like:

  "listenOn": "tcp://localhost:50001",
  "pubOn": ["tcp://*:9505"],
  "debug": false

That’ll listen on port 50001 for the CMS to connect to only on the local interface, and all interfaces port 9505 for the Players.

What you’ve got in that config file would be the correct entries to put in to the CMS, not XMR. It’s also different from your first post where you had an IP address, so that’s why we’ve not picked it up.

Hi Alex,

I have amended my config.json to what you have stated above. I think I now understand what ports are used for CMS and players now, thanks for the explanation!

When running xmr.phar from CMD it still only provides the first line and quits. Is there a way to find out whats causing this not to run? Any logs I can check, windows or otherwise? I’ve had a look in all the usual places like event viewer etc but no such luck.

Thanks again for taking the time to reply.

I’m not sure where else you can look off the top of my head. I’d expect to see any errors on the console not in the event viewer etc.

Perhaps try substituting the * for your actual local IP address, and the same for localhost, substitute it for

Hi Alex,

Nope, still no such luck sadly. I’ll see if I can come up with a solution and if so post here.

Thanks for your input.