XMR for Commands

Hello,

I need help for problems of XMR. I’ve running CMS with Ubuntu Server 18.04 & Docker. CMS running well and all requirements are installed so I want to push communication to player with command;
xmr2

And this is my command configuration;

But player doesn’t receive communication. I tried to reboot manually and kill Watchdog and Client but still doesn’t work for me.

This is player status for Windows;
xmr1

So XMR already connected to my tcp but still doesn’t work. Make sure for Reconfigure XMR on Display Edit but yes, still doesn’t work and I got this error message;
xmr4

Why error? I’ve installed ZeroMQ and XMR on my CMS and I already set to my tcp on Setting like this;

So I want to make sure again on my Server for XMR are installed or not. And XMR was successfully running on port 9505;

Any solution? I need help for this. Thank you.

Hi Linuxenic,
It works for me, may be you should activate command shell in your screen profil


Tell me see you
Fred

Thanks for your answer, Frederic.

I’ve completed this step for true command shell and still not working. But this topic was solved by allow TCP 9505 from AWS Security Groups. So, the problem is need more to config network communicate on AWS.

image

Yes, I’m using AWS for CMS. Your answer is important for Developer who using another VPS or etc.

Thanks for your reply. Add it to my Xibo Codex :slight_smile: