XMR Communication Issues

I am struggling with XMR
In my display area it shows my one windows screen as XMR registered.
I am trying to perform the “take a screenshot” feature.
When I try it mentions to activate the Screenshot column, which is, and I have also activated the thumbnail column. After request, the pop up says the screen should be immediate, but may need to refresh if not.
Nothing ever comes through.
In the logs, I receive these errors;

802 420d783 2018-02-16 09:17 WEB PUT ERROR /display/requestscreenshot/1 Unable to Process Queue of Player actions due to 1 of 1 player actions failed
801 420d783 2018-02-16 09:17 WEB PUT ERROR /display/requestscreenshot/1 Player action refused by XMR (connected but XMR returned false).

Have I missed something on the client windows player for XMR capability?


Which CMS version are you using and is it docker or manual/custom installation on a web server?

1.8.5 (just upgraded to, but had problem on 1.8.4 my original install aswell)
It is a manual config using Windows server with Apache2, and php5 (already existing web server I had)

Is the zeroMQ installed and enabled? (you can see that on Report Fault page Environment check)

If it is, then you need to ensure that XMR is correctly configured in config.json and in CMS settings, and of course that the XMR itself is running - https://xibo.org.uk/manual/en/install_xmr.html

If you have any other services running on your web server if could be a good idea to ensure that there are no ports conflicts between them.

Unfortunately on manual installations there are additional steps to get that to work compared to docker.

looking at the results from Report Fault page, all items are checked.
I had already configured the config.json in the vendor/bin area.
The listenon is tcp://localhost:50001
the pubOn is tcp://{mywebserverIP}:9505
and debug is false

I did miss a setting in the CMR part about setting the XMR Public address against the display - not entirely sure what I should enter here though so have just entered the {mywebserverIP} - no transport type or port before or after though - is that correct?

I am also unsure about thie XMR as a Phar thing. I did run that as a process from a DOS command line once, but it seemed to hog all the CPU so closed it down. Is that a necessaity too? unfortunately the notes on this point are geared towards a linux environment.


You do need to run XMR server all the time, in a DOS window, or arrange for something else (eg the task scheduler) to run it at startup and keep it running.

It uses almost no CPU in normal operation.

In the CMS settings, you’ll need to enter two addresses.

XMR Private Address, which will be tcp://localhost:50001 (assuming your XMR is running on the same as the webserver), and then XMR Public Address will be tcp://{mywebserverIP}:9505

That IP (or DNS name) needs to be accessible by your Players.

not sure what has changed but now when i try to run “c:\php\php.exe xmr.phar”, but i get a stack of errors.
the most important i guess is xmr.ERROR: Failed to vbind the ZMQ: No such device [] []

But everything points to ZMQ working?

Also since trying to do the rekey, my display says no longer XMR Registered… 8(

It’s telling you that either “localhost” doesn’t exist, or it points to a network device that isn’t valid in some way, or the same for {mywebserverip}.

If you’re sure the IP is correct, try changing localhost for instead.

you are indeed correct! altered my config.json to and it has loaded. However CPU has shot back to 100% .
I terminated and turned on debug and re-ran and still the same,
very little notification.
xmr.INFO: Starting Up - listening for CMS on tcp:// [] []
xmr.INFO: Bind to tcp:// for Publish. [] []
xmr.DEBUG: Adding a queue processor for every 5 seconds [] []
xmr.DEBUG: Heartbeat… [] []
xmr.DEBUG: Heartbeat… [] []
xmr.DEBUG: Heartbeat… [] []

You’re sure it’s XMR causing that? It essentially does nothing until it receives a message, so I’m not sure how it can be using that amount of CPU time.

for definate. The moment I terminate the console my CPU drops back to 1-2%

That’s not telling you it’s XMR using that CPU though. It could be a software firewall for example.

Our preferred way to run Xibo CMS is with Docker. We try to offer some assistance for those with a custom install, but unfortunately we can’t help in every case. I’d suggest looking at any firewall or antivirus, and see if one of those is causing an issue when XMR is running.

Failing that, I don’t have any ideas as to why that would be happening I’m afraid, but would suggest you run Xibo inside Docker on a Linux machine where we are best able to help you.

I appreciate that.
Thanks for your assistance so far.
And BTW, thanks for a great piece of software.
I had tried many variants before settling on this as this seemed by far the most logical and easiest to me.

1 Like