XMDS error after upgrade


#1

I upgraded CMS yesterday to 1.8.12. Everything on the CMS seems to be working properly. Unfortunately, when trying to add a display I get the following message “There has been an unknown error with XMDS, it has been logged. Please contact your system administrator”. Upon research I’ve seen articles suggesting the ‘COMPUTERNAME’ in the default.config.xml and config.xml could be wrong but these both seem correct. Is there anything I’m missing?

CMS is hosted on Ubuntu 18.04.2 using Apache2
I’m adding a windows display using 1.8.12 according to the ‘About’ section in the player options app.

Thanks for any help in advance.

Matt


#2

Hi Matthew,

Did you ever get to the bottom of this? The reason I ask is that I have exactly the same problem. I’ve upgraded to 1.8.12 and am unable to add a new display. The resulting error is the same as yours. I wrote a similar post a couple of weeks ago but as yet have not been able to solve the problem…

Thanks in advance!


#3

I am going to suggest you check out this link and see if making the small change to the file “/lib/Xmds/Soap4.php” will solve your issue. Modify the red highlighted line of code with the green code.

Andre


#4

I didn’t subscribe to this topic after my comment, however, I have just noticed your replay. Thank you for the suggestion, however, I have just upgraded to version 1.8.13 and this has solved the issue. I wonder if this fix has been included in 1.8.13 and this is why the latest version has solved the issue for me?