XIBO windows docker tool box installation -shared folder not getting created


I was installing xibo cms in docker tool box windows 8.1 .

Installation completed but shared folder is not getting created.

Any solution

if i run docker-compse up -d

Could run docker-compose down and then docker-compose up (without -d) it will show you what is doing, if there is some sort of an error it should be logged there.

I wonder if you have similar problem perhaps? Xibo works only untill first layout change is made

I saw you linked to a topic created by me where I mention also this problem regarding the shared folders. The solution in that topic is however for a different problem.

As mentioned in the topic I was also experiencing problems with the shared folders. I fixed it using absolute paths in the docker-compose file instead of relative paths:

- “/c/Users/xibo-docker/shared/cms/custom:/var/www/cms/custom”
- “/c/Users/xibo-docker/shared/backup:/var/www/backup”
- “/c/Users/xibo-docker/shared/cms/web/theme/custom:/var/www/cms/web/theme/custom”
- “/c/Users/xibo-docker/shared/cms/library:/var/www/cms/library”
- “/c/Users/xibo-docker/shared/cms/web/userscripts:/var/www/cms/web/userscripts”

Path given was wrong
instead of