Xibo v4 - DataSet no data template

Hi, we are using the DataSet Feature for an Event Screen, which shows automtically the event running today and the relevant times.
However, we sometimes have Events that are not in the Dataset. So in Xibo v3, i created a “No Data” Template to show some standard Information. In v4, it seems to be not longer possible to set a no data message for Dataset Elements in Layouts, is this right?
Is there any other solution to do this?
If anybody is interested, i can provide our layout in Xibo v3 to give you more understanding about the problem.

Xibo v3:

The no data Option is missing in v4:


Hi @dan and @natasha!

I just realized this… I’m sorry, but his point is extremely valid!
Now, I’ve just noticed that there’s no way to have free HTML + CSS editing in the dataset module!

Take a look of a birthday layout I use with Datasets:

In it (in version 3), I insert a video with an opening vignette, and then a Dataset ticker that filters those who have a birthday on the current date and displays them in a customized layout containing a photo, birthday date, name, etc…

Each row of my dataset contains these columns that are consumed in the layout one by one… (like the picture, name, birthday date, etc)

This is very important, How can we create these customized layouts (which are an extremely powerful tool) without the ability to edit HTML + CSS ?

Thank you!

1 Like

And i just realized that when i migrate my CMS, all of those layouts are not beeing migrated… The dataset ticker is just deleted

You are right, the DataSet Ticker seems to be no longer available in v4. In other threads, the developers mentioned that they are aware of this and are implementing a solution in 4.1, but in the milestones on github i couldn’t find any related issues.

Oh, I didn’t know that.
Well, let’s wait for their feedback in this case :wink:

@dan are there any information on this from developer side?

Hi both!

You’re right that currently there isn’t a way to do this with DataSet Elements, which is a miss from our side. We’re planning on enhancing this in 4.1 by creating a way to set a sample data item to use when there is no data returned.

In the meantime we’ve added a static template in 4.0.5 which is available when you’re inside a Playlist. This has the old v3 template and “No Data Message” options. Just add a playlist and then add a DataSet widget as normal.

I think you should be able to do the birthday example with DataSet Elements - except the missing non data message?

Beyond that the HTML/CSS/JS options can be implemented using the developer tools but we need to make these more accessible. We are hoping to add some more examples and improve the documentation, and will do that once v4.0 has stabilised a little more.

In v4.1 there will be an in-CMS user interface for creating modules and templates, which saves the relevant XML into the library for reuse across the CMS.

That definitely shouldn’t be the case - no widgets are deleted during the upgrade process. It may be that there is some missing logic we need to add to the upgrade to cater for the options in your widget. If you could provide an export we’d be happy to look into it.


Thank you for the tip! I managed to enable it through the developer tools as you guided.
Now the Dataset with custom HTML can be used in the playlist.

For those who want to enable it as I did:

Find the template <id>dataset_custom_html</id>

Change the <showIn>none</showIn> tag to <showIn>playlist</showIn>

Now, in the playlist, you will see the option to insert a Dataset with custom HTML:

The missing “DataSet “No data”” issue has really broken my CMS layout that relied heavily on Datasets for scheduled exams. (What group is writing what subject in what room.

I hope that Xibo can fix this in 4.1, otherwise I will have to see if I can restore the CMS back to prior to 4.x. s there some way of accessing older legacy CMS installs?


How can I edit the file on a docker installation? There is no vi or nano installed.

Thank you,

You can override CMS files by placing them in the custom folder and pointing to the location where they are stored within the container in your docker compose file at the “volumes” part.
For example:

Sorry, but I don’t understand that.

I have changed the file now, then I placed it into the “shared/cms/web/theme/custom” folder.
my cms_custom-ports.yml file has this line:

 - "./shared/cms/web/theme/custom:/var/www/cms/web/theme/custom:Z"

I think that is wrong. Do I need do copy the whole templates folder and paste a line?


You need to map this in each file that you want to customize, for example:

Thank you.
Now it works.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.