Xibo v4 content not publishing on the display giving fonts.css error

I am facing a issue in xibo version 4.

The content is not uploading into tizen display and giving font.css error

On the display page status is keep showing “Display is downloading new files”

I had the same problem and eventually it worked itself out. I am not sure if some background task runs periodically that fixes it. You could try to check out a layout and then republish it and see if that does it, I did that around the same time my error cleared.

Fonts.css does get generated by a background process, so if your XTR isn’t running that would be a good place to start investigating.

Beyond that, it might be that your display has an outdated cached list of required files, perhaps that wasn’t cleared for some reason. If you edit the display and save it will clear the cache.

@wer83 @dan Thanks for the reply

My issue still not fixed itself , in the manage display font.css still uploading

@wer83 I tried check out layout, even tried with creating different layout and publish but still same.

@dan I tried factory reset and clear cache of the display but still no success.
I did my installation through Xampp in windows server. What’s XTR and how can i check if its running?

You can look on the tasks page in the CMS and see if their run dates are increasing. More info here: Xibo on a Web server | Xibo Digital Signage


looks fine, i can see date and time updates with every refresh

Correct me if I am wrong but the “Last Status” column seems to indicate it is not running? Mine shows check marks and not X’s.

1 Like

Spot on - the “last run” date is not filled in and the status is X which means XTR isn’t running.

You need to set up a windows scheduled task to regularly execute the task runner, information for how to do that is in the link I sent you.

I am seeing this issue on a Docker installation 4.0.6 out XTR tasks do not appear to be running. Does anyone have any ideas?

Versão: Player Android v4 R401

I have the same problem, but my tasks are being carried out normally, even so my Player does not download the Fonts and consequently never finishes the update, leaving an X in the status of the Players page.

As shown in the image below.

@dan Could you give me some guidance?

If you go to Administration → Fonts and then use the Row Menu to “View Detail” on those fonts - are they shown correctly?

If not, please can you delete those fonts and upload them again?

Displays the following fonts @dan

If trying to display font details generates an error.


@dan Anything you can do to solve this problem?

Hi,

I also have this problem with the fonts.css file which refuses to download to my displays.

I left it for several days without touching it but the error does not go away.
My tasks seem to be working well.

I am currently testing on Xibo CMS 4.0.6 under Windows Xampp.

I have three players, one in version 3 and the other in version 4…
One Windows version player, the other Android version…

both are impacted!

How can I correct this problem which seems to be recurring in this version of the CMS?

PS: I have another CMS server in version 3.0.4 under Windows Xampp, tested with the same players, but I don’t have this fonts.css problem