xibo time is not correct

I’ve installed a Xibo server using xibo docker image from dockerhub on an Ubuntu 20.04.
The Ubuntu server date, time and timezone is showing properly. But the timestamps in xibo webpages are not correct and they are different from the real time . I’ve change the timezone from the setting menu but timestamps are still not correct.

Also I’ve checked time setting inside the docker containers and came to know that docker containers of the Xibo server have diferent time from the host (Ubuntu server) .
When I try to change the time inside the docker containers I get this error:
“date: cannot set date: Operation not permitted”

Because of this problem I can’t use xibo schedule.

Please someone help me how to synch xibo time with the hosted server time?
Thank you

Hi arsalan, welcome to the Xibo community!

My apologies but I was a little unsure from your post which Xibo webpages you are referring to that have the wrong timestamps? Can you provide a screenshot?

If you go to the Settings menu in your CMS, then choose the Regional tab, can you make sure Detect browser language is not ticked, save and refresh the page? Do you still see the incorrect time?

Many Thanks.

Hi Dan,
Thanks for your reply. Here are come details:
Regional settings in xibo web:
Default Language: en_GB
Timezone (GMT+3:30) Asia, Tehran
Date Format Y-m-d H:i
Detect language : Unchecked
Calendar Type: Jalali

The Ubuntu server and docker containers time and date:

admin@xibo:~# date
Sun 16 Oct 2022 10:31:28 AM +0330

admin@xibo:~# docker exec -it xibo_cms-quickchart_1 date
Sun Oct 16 07:01:31 UTC 2022
admin@xibo:~# docker exec -it xibo_cms-xmr_1 date
Sun Oct 16 07:01:31 UTC 2022
admin@xibo:~# docker exec -it xibo_cms-db_1 date
Sun Oct 16 07:01:31 UTC 2022
admin@xibo:~# docker exec -it xibo_cms-memcached_1 date
Sun Oct 16 07:01:31 UTC 2022
admin@xibo:~# docker exec -it xibo_cms-web_1 date
Sun Oct 16 07:01:31 UTC 2022

A sample screenshot of time stamps

When the correct time is 1401-07-24 10:30
Xibo shows 1401-07-24 07:00

Thank you

I have the same result when checking ubuntu time and docker time. Ubuntu time shows Amsterdam GMT+2 time and docker is in GMT time. But in my case the schedules work as it should.

Did you also checked the time/date on the player itself?

Date and time in player machine is correct.
In schedule section if “Run at CMS Time” left unchecked the scheduled event run on time. But if I mark it then the event will play at a wrong time.
I can Manage scheduling with respect to time difference or uncheck "Run at CMS Time? " .
My problem Time stamp in layout page. I hope someone help me to resolve this issue.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.