Xibo & SWAG (NGINX webserver) all running in docker

Please do post your query into one of the available Categories available for this ‘Get Help’ section, so that you can be best supported!

Where to start… Recently started self hosting found a lovely VPS in Linux server SWAG is based on an NGINX module that auto validates for ssl hosts many popular containers but it does not however seen to host this one…

Have attempted the proxy, the subfolder ubder the proxy-confs and even the Default file under the site-confs. Have review Alex’s posts on NGINX but with the newer versions of Ubuntu am not getting anywhere

Attempted xibo.subdomain.conf

Version 2020/12/09

server {
listen 443 ssl;
listen [::]:443 ssl;

server_name xibo.*;

include /config/nginx/ssl.conf;

client_max_body_size 0;

# enable for ldap auth, fill in ldap details in ldap.conf
#include /config/nginx/ldap.conf;

# enable for Authelia
#include /config/nginx/authelia-server.conf;

location / {
    # enable the next two lines for http auth
    auth_basic "Restricted";
    auth_basic_user_file /config/nginx/.htpasswd;

    # enable the next two lines for ldap auth
    #auth_request /auth;
    #error_page 401 =200 /ldaplogin;

    # enable for Authelia
    #include /config/nginx/authelia-location.conf;

    include /config/nginx/proxy.conf;
    resolver 127.0.0.11 valid=30s;
    set $upstream_app 192.168.101.31;
    set $upstream_port 8080;
    set $upstream_proto http;
    proxy_pass $upstream_proto://$upstream_app:$upstream_port;

   proxy_pass              http://127.0.0.1:8080/;
   proxy_set_header        Host                    $host;
   proxy_set_header        X-Forwarded-For         $proxy_add_x_forwarded_for;
   proxy_set_header        X-Forwarded-Proto       $scheme;
   client_max_body_size 4G;

}

}

and xibo.subfolder.conf

location /xibo {
# enable the next two lines for http auth
#auth_basic “Restricted”;
#auth_basic_user_file /config/nginx/.htpasswd;

# enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
#auth_request /auth;
#error_page 401 =200 /ldaplogin;

# enable for Authelia, also enable authelia-server.conf in the default site config
#include /config/nginx/authelia-location.conf;

include /config/nginx/proxy.conf;
resolver 127.0.0.11 valid=30s;
set $upstream_app cms-web;
set $upstream_port 8080;
set $upstream_proto http;
proxy_pass $upstream_proto://$upstream_app:$upstream_port;

}

and under the default file

location /xibo {
# enable the next two lines for http auth
#auth_basic “Restricted”;
#auth_basic_user_file /config/nginx/.htpasswd;

# enable the next two lines for ldap auth, also customize and enable ldap.conf in the default conf
#auth_request /auth;
#error_page 401 =200 /ldaplogin;

# enable for Authelia, also enable authelia-server.conf in the default site config
#include /config/nginx/authelia-location.conf;

include /config/nginx/proxy.conf;
resolver 127.0.0.11 valid=30s;
set $upstream_app cms-web;
set $upstream_port 8080;
set $upstream_proto http;
proxy_pass $upstream_proto://$upstream_app:$upstream_port;

}

keep getting a 403. Am hoping for some insight
Thanks in advance

The Xibo Community site uses cookies. What are cookies?