XIBO Reset to Default - Start / Stop not working


Came back from vacation today and need to update some slides. Couldn’t log in to system with what I thought was the password. Logged in using default creds, noticed displays were gone and layouts empty.

Found article here; https://xibo.org.uk/manual/fr/install_docker_win10_64bit.html which said to run docker-compose stop and start. Ran commands successfully. System still in default state. Tried rebooting the VirtualBox and tried again, same issue.

Any help greatly appreciated.

I assume the /shared directory along with the /library /db in it is still present?

If so, I’d perhaps suggest you to, run the down command, reset the docker to factory defaults, re-share the C drive, run the up command.

Whats weird is I’m not seeing it, unless I’m looking in the wrong directories. The shared directory would be the same directory i’m running the docker-compose commands from, correct?

My failings at following instructions were my issue. For whatever reason I never verified a shared directory existed, nor did i verify that the docker / xibo directory was in C:\Users.

After downloading the xibo-docker files, and extracting to C:\Users\xibo-docker - I was able to run docker-compose up -d and a shared directory was created.

Thank you for your time.

Yes, as you’re running the command where xibo-docker files are and /shared should be created in the same path.

Interesting, so when you had it previously the /shared directory was not created at all?
I’m sorry to hear that if that’s the case, perhaps that was a permission issue in the path you tried to install it previously.

Now, that you do have the /shared directory, please also double check if you can upload a file to the CMS, make sure it does appear in the CMS library (/shared/cms/ibrary) and that you can download from it as well - I’d expect that to work fine, since there should be no permission issues in your current path, however just in case it might be good to double check that.